Matrix probe broken in 5.1.5?

    Sep 07 2010 | 1:24 am
    I use matrix probe often when debugging things, but after installing 5.1.5 it has stopped working for me. I've tried several different patches, restarting the program and restarting my computer. Anyone have any ideas?
    Running 10.6.4, Mid 2010 Macbook Pro, 8gb ram
    Any future chances of having a version of this for opengl cords? or would that be too complicated in terms of rendering processes? I have a preview window built into mine but it was a bear to implement.

    • Sep 07 2010 | 7:24 pm
      Seems to be (mostly) working here. Does it work with the most simple patch? Did you try to trash Max Preferences?
      Preferences are stored here:
      ~/Library/Preferences/Max5 Preferences Folder
    • Sep 07 2010 | 8:03 pm
      Thanks, I gave that a shot but still no luck. My graphics card has been acting up lately so that could be a clue. I tried it on a simple jit help patch and it wasn't any different..when I hover over patchcords the probe just shows n/a for all of it's values.
    • Sep 07 2010 | 11:22 pm
      One thing to check is to make sure that you have the jit_matrix-probe.maxpat in Max's search path. It is installed here:
      Max5/Cycling '74/interfaces/jit_matrix_probe.maxpat
      If you don't have this floating around somewhere, best to do a clean install. To clean out Max 5 entirely, remove these items:
      ~/Library/Preferences/Max5 Preferences Folder /Applications/Max5
      Then download and reinstall Max 5.1.5:
    • Sep 08 2010 | 3:45 pm
      Yeah it's there. I opens and everything just just doesn't work like it used to on my older macbook. Isn't it's operation just to show in it's screen what is currently passing through the green/jitter patchcord you're hovering over with your mouse? No watchpoints or anything need to be set etc
      I'll give a re-install a shot I guess...
    • Sep 28 2010 | 11:56 pm
      Man...this is one of those stupid answers. Somehow I had disabled 'probing' in the debug/preferences and of course that turned off my matrix since I've turned it back on it's all good...haha