Max 5 vs Externals

    Jun 09 2010 | 9:17 am
    I'm sorry to start a new topic for just a ridiculous question but I've been surfing this forum and the web for three hours without finding an answer to my problem.
    THE PROBLEM: Max just doesn't load my external. The external is called xsample by Thoma Grill (
    WHAT I DID: I've put the file in the Cycling'74>msp-externals folder, and the help file in the Cycling'74>max-help folder as I successfully did on my old computer months ago.
    I also tried a bunch of different location also trying to force the loading by setting the externals path inside Option -> File preferences...
    WHAT HAPPEN: 1 - I open max and try to create a new object called [xgroove~] which is part of the xsample external; but it doesn't work and I have a solid outlined block with no inlets and outlets.
    2 - If I make an object called [xsample] I have the same not recognized block but on the max window I see that max has loaded the xsample externals and all its friends.. Then if I make the [xgroove~] it works perfectly, but the xsample still remains orange/red colored.
    3 - If I save the file with the two objects, quit max and launch the file again, Max doesn't recognize the objects but the Max window tells me that the external was loaded correctly...
    4 - When Max tells me that the external has been loaded the help file works.
    ABOUTs: Max version: 5.1.4 Computer: Mac OSX 10.6.3 - Intel Core i7
    Thank you everybody.

    • Jun 09 2010 | 10:16 am
      Hi - you're right, this is a bit confusing. The Xsample object is not an object itself it appears, but a collection of three objects. So you need to type in either xgroove~, xplay~ or xrecord~. I don't see a help file in the zip though so i can't see how you are seeing that..
    • Jun 09 2010 | 10:50 am
      The problem is that the xsample seems not to be loaded when I launch Max but it is loaded only if I create the object xsample which is kind of weird...
    • Jun 09 2010 | 11:01 am
      I can only confirm that it's the same here.. It's something to so with the class definition; it's happening when an object is initiated rather than when max itself loads. The source code is available so it would be easily modifiable.
    • Jun 09 2010 | 11:08 am
      sounds a bit like you didn't put the xsample-objectmappings.txt file in the init folder..
    • Jun 09 2010 | 2:25 pm
      Hi AS! What do you mean by init folder?
    • Jun 09 2010 | 2:42 pm
      I mean the folder named init in the cycling74 folder. Some objects require a text file with object mappings so the objects can initialize upon starting max 5. And on my laptop I have xsample-objectmappings.txt located in that folder.
    • Jun 09 2010 | 7:48 pm
      object mappings, like for the !/ object... not an allowable filename. So if the user puts that into an object box, it won't look for that file, instead the max-objectmappings.txt file says to do this:
      max objectfile !/ rdiv;
      so it looks for a file called "rdiv" instead.
    • Jun 09 2010 | 8:28 pm
      Ok, if that's true, it means I've somehow, along the path of life, made my own explanation up. And actually started to belief in it. And I think that's the case. :)
      But still without that file the xsample objects won't work properly is my recollection.
    • Jun 10 2010 | 7:05 am
      You are right AS! It was due to the xsample-objectmappings.txt file! In the meanwhile I've also emailed the developer Thomas Grill who wrote me teh following:
      " xsample is a package of externals that needs the individual objects to be referenced. Have a look at the readme file "
      So I did it and now it works correctly! Next time I'd better read carefully the readme file...
      Thanks everybody!