Max 6.1.7 doesn't respond to iTunes 11 using Soundflower and headphones


    Jun 03 2014 | 9:40 pm
    My Jitter patch allows images to respond to sound from iTunes through an external or internal microphone. This doesn't work when listening through headphones. I've followed instructions on the Soundflower page and think they should work - however no response on screen. I've also tried with an Apogee Duet and nothing.
    Does anyone know what the problem might be?
    Thanks

    • Jun 04 2014 | 6:30 am
      The setup you've described should work, you might want to check that the output/input settings are as follows:
      You Mac's system output (Set this in System Preferences > Audio) need to be set to Soundflower Output (1&2). Your Audio Settings on Max/MSP should have the Input set as Soundflower, and your Output should be set to your Headphone Output.
      Once set in this way, do you hear audio?
    • Jun 04 2014 | 12:59 pm
      Thanks.
      Set up exactly as you describe (or with my Duet) I hear output on my headphones no problem, however what I also want is for the input to Jitter to show up as deformation of my video playback. The patch works perfectly with any microphone source and iTunes (or other sound) playing, but not with headphones.
      I'm doing this because I need to rehearse at home without sound in the room - and hoped it would work. Max needs to take the sound from iTunes and allow that to influence the patch then also allow me to hear it at the same time through headphones.
      Seems simple - so either I'm doing something wrong or it's just not possible? I'm asking the same question of Apogee.
      Apogee's response: "Due to the modular complexity of Max/MSP unfortunately this would require contacting Cycling 74 for assistance."
    • May 18 2016 | 9:55 pm
      2 solutions to this problem - almost 2 years later:
      b