Max 6: Patches won't be saved in specified location


    Jul 29 2012 | 1:11 pm
    Hi all,
    I'm having issues saving my patches on Max 6. The patches or projects are being saved, but not where I'm telling Max to do it. This is happening every time I save a new patch/project, and sometimes saving an existing patch.
    Usually the patches ended up being saved in Applications --> Max 6 folder (mac).
    I made sure that the folder in which I want my patches to be saved is a declared path under "File Preferences".
    Is someone having the same problem?
    Thanks,
    Carlos

    • Feb 27 2013 | 11:16 am
      Hi Carlos,
      I'm having this problem now! Did you ever manage to sort it?
    • Feb 27 2013 | 9:51 pm
      You need to provide an absolute path. Not by changing file preferences.
      e.g. write /my/folder/filename.txt to put the file filename.txt in the folder /my/folder
    • Feb 27 2013 | 10:07 pm
      Sorry I see that you're referring to patches. You'll need to post a much clearer description of what you're experiencing and expecting. Step by step.
    • Apr 12 2013 | 2:01 am
      I'm having the same problem. It also won't let me set the default project save folders to the folder i want - which is a folder within My Documents. I'm wondering if the two are related. It seems everything sames in an msp tutorial patch folder, which is the first place I accidentally saved something. When I move patches out of that folder, it just moves an "alias" unless I trick it by sending it to the trash then moving it back to a different folder from there.
      The problem that is most frustrating, which I also assume is related, is that I can't access saved patches as new objects, and even copying and pasting them from another file they come up as a grey box instead of white, can't be accessed, and don't do anything. I created a new patches folder and set it to that in Max, but it doesn't seem to be recognizing that folder. I'm on OS X 10.8.2, a retina MacBook pro. I'm very new to Max. Thanks for your help!
    • Jun 14 2013 | 7:22 am
      A perfect description of the problem, I'm handling right now! did anybody found a solution and can share the answer here?
      Thanks for your help!
    • Jun 14 2013 | 7:50 am
      Never happened to me with 10.8.2 or .3. Are you talking about patches or projects ? This still isn't clear to me.
    • Jun 15 2013 | 8:50 am
      ah, thanks for the hint "project folder". using them - what make sense - solve this problem! I'm quite new to max and did't know how files are organized.
    • Feb 14 2014 | 1:54 am
      has anyone found the solution to this? I'm having the same issue
    • Feb 28 2014 | 8:47 pm
      Also waiting for an answer! It's quite confusing.
    • Jun 03 2014 | 7:21 pm
      I am having the same problem. I've been using max for 6 months bug-free, but when i installed max on a new SSD this problem began happening right away. I'm not concerned about a default save location, I'm concerned with Save/SaveAs->Selecting a location->saving->My patch is now the name i chose through saving->but it's not located in the directory i chose, it is in SSD/Applications/Max6/"filename".maxpat, which I assume is the default directory.
      I have a lot of very different projects, I want to be able to organize them my way, not have them all lumped into the default folder. Can someone please offer a solution to this problem?
      Thank you very much!
      Michael
    • Jun 03 2014 | 8:04 pm
      AHA! Well, I solved my problem, at least. The folder I was trying to save to was called "MAX/MSP" The "/" was the culprit. So I guess that Max is rather smart in that it automatically reroutes the file to a default folder in case it cannot save to an invalid directory. At the very least this, helps from someone losing their work, I guess.
      I hope this helps you guys out!
    • Apr 19 2015 | 12:50 pm
      I realise that this is quite an old thread, but I just started having the same problem with Max 7.0.3 ..... patches are being saved inside a folder in the max application, rather than the specified folder. Did any of you figure out definitively what was causing this? It is becoming quite infuriating!
    • Apr 20 2015 | 4:20 pm
      did you confirm you don't have a "/" in any of the folder names of your specified path?
    • Apr 21 2015 | 4:16 pm
      Hi Rob,
      Yes, there is definitely no '/' in the path...... in face, I was trying to save a patch into a folder which already existed; the problem only started when I installed v7.0.3.
    • Jun 27 2016 | 4:26 pm
      Any movement on this? I'm finding the same problem. Thanks.
    • Jul 05 2016 | 2:07 pm
      same problem here.
    • Jul 05 2016 | 5:23 pm
      I was getting all kinds of problems, like patchers not updating , files in recent patchers not loading, having to select replace file every time I saved a patch, all caused by having the name "kits/trig" for the folder I was saving the patches into. Get rid of the "/" and it all works normally.
    • Jan 26 2017 | 11:05 am
      Just bumping this thread and chiming in "me too!"
    • Mar 03 2017 | 9:43 pm
      Most recent update corrects this.
    • Apr 06 2017 | 1:55 pm
      I still had the same problem with Max 7.2.3. When I removed the "/" out of my folder it worked. I suppose this isn't completely fixed yet?
      Thanks anyways for the answers. It saved me from going crazy!