Max and Vienna Ensemble Pro

    Sep 12 2013 | 12:29 pm
    I am trying to use VEP as my mixer with Max and have an odd problem. If I use the VST version of VEP in Max, I can route audio between Max and VEP with no issues. However, no audio unit plugins have any affect in VEP - it is as if the plugins are simply bypassed. I thought that this may be due to the fact I have used the VST version in Max, so I then used the AU version of VEP in Max and while it connects just fine, no audio is being routed between both programs. So I am left with either VEP where I cannot use any effects (seeing as it does not use VST's) or nothing. I am not receiving any error either way - it just seems to be the way it is. Has anyone else tried this? Was Max ever tested for use with VEP - both AU and VST versions?
    Thanks, Trevor

    • Sep 12 2013 | 6:12 pm
      Hi, I do not understand what you are after. You wrote you can route Audio from Max to VE but thats not- as far as I understand- the purpose of VE. I thought it hosts virtual instruments that can be triggered through different midi channels from a host (in your case max). But why should one route Audio through VE. Please explain.
    • Sep 12 2013 | 6:29 pm
      I think you misunderstand what VEP's main use is. Yes it can host virtual instruments (and it is very good at it too), but the main use of it is to take audio from multiple sources (several applications on one computer or even applications running on other computers as long as they are on the same network) and mix all sources in one place. Actually, you would hear absolutely nothing if you did not route audio from VEP as there is no such think as a direct audio out - only to send audio to a host application through VEP's internal bus. Using it to mix audio from Max is extremely useful as you can route audio a lot easier, create busses, add effects easily etc in VEP with low CPU usage without the need for another DAW - something that would be more cumbersome to do in Max.
      In any case, it was a silly mistake on my part - I was working on a project where I had to run Max in 32 bit and had not unchecked that attribute. Changing back to 64 bit resolved it. Having said that, the AU version of the plugin still does not work in Max - the VST one is fine though and AU plugins are happily working in VEP now.
      Cheers, Trevor
    • Sep 12 2013 | 6:39 pm
      Ok, thanks or the explanations. I have only VE without Pro and I think it can not do what you describe..? The problem I had with VE (non Pro) was that I got a heating problem with my macbook pro, but you say VEP is rather cpu friendly?
    • Sep 12 2013 | 6:59 pm
      I find it to be very CPU friendly - it distributes CPU demands incredibly well across cores. Many people use it (with Logic especially) for the reasons you outlined - if you have a multi timbral instance of kontakt or similar running in Logic, all instruments are using the same core. Not so in VEP meaning you don't get CPU overloads when 6 or 7 cores are doing nothing! Similar when monitoring inputs which all happens on the eighth core in Logic. Along with mixing over network, that's the main reason I bought it as I want to monitor 16 inputs live. The 16 inputs on their own is fine on one core, but when you start adding plugins, you overload quite quickly. Adding most effects in VEP completely nullifies this issue!
    • Sep 12 2013 | 10:31 pm
      I would buy VEP in a minute if it didn't require a USB dongle (sigh)
    • Sep 12 2013 | 11:28 pm
      Yeah, a bit of a pain in the ass. Worst part is that if you lose the dongle, you lose your software - no come backs.
    • Jul 16 2014 | 9:30 pm
      bit of an old thread, but has anyone got this working?
      Im trying VEP (5.3) with Max/Msp 6.1.7 on osx 10.9.3 and midi doesn't seem to work at all.
      Ive tried both running midi events into the VEP server audio unit directly, and also instantiaing a separate VEP event input audio unit.
      In both cases, I can see no midi activity within the (local) VEP instance (and of course therefore no audio)
      Ive tried both the audio unit of VEP server/VEP event input and the vst version, but both the same.
      (I know my Max patch is fine, as I can run any other VST without issue)
      Its odd, I've got no issues running the VEP vst/audio units in any other host.