Max causing Motu 828mkII Dropout?

    Aug 28 2009 | 6:57 pm
    My Motu 828mkII loves to have drop outs. It seems to be OSX resetting the firewire buss a lot or something. I've been tracking down and eliminating various causes for these dropouts and Max is up next.
    When I run Logic 9.0 and have Max as a rewire client after a while I get a dropout. By dropout I mean audio is replaced by a high pitch tone and I have to reset pretty much everything to get going again.
    Looking at the console there is this message- 8/28/09 11:41:25 AM [0x0-0x2c02c].com.cycling74.MaxMSP[372] freebytes: trying to free bad ptr 1311c608
    Not sure what this means but it has corresponded with a lot of these dropout problems.
    Any ideas? Thanks!
    I'm running OSX 10.5.8 on a Macbook Pro.

    • Aug 28 2009 | 9:34 pm
      yes, the high pitch tone means firewire dropout, which can be the OSX driver, (when it is not a bandwith problem.)
      i have used 828 mkII with OS9 and windows and never had problems. in OSX i had it at least one time that audio stopped working and i had to reboot.
      no ready solution, sorry, but you might want to try disconnecting unused ports (3-8?) in the max setup and/or try other driver settings (mainly vectorsize.)
    • Aug 29 2009 | 11:01 am
      i have a FW 828 mkII and i don't get any dropouts like this. maybe yours is faulty or you have a MBP with a bad FW chipset. Do other cards have problems?
    • Aug 30 2009 | 7:07 pm
      I never ever had problems with my MOTU828mkII. But today yes... after 3 weeks without loading max. (nothing comes out/or high pitches)
      -I might have upgraded my OSX(10.4.11)since. -Firefox for sure...(mgh!).? -iTunes(I did not upgrade that one. I want to keep my EQs...).. iTunes plays well but as soon as Max audio is ON, iTunes stops and high pitches start. -SoundHack doesn't play either (I get high pitches as well...)
      System preferences/audio : it seems to get audio IN from MOTU. but concerning output: «The selected device has no ouput control»
      I would appreciate some help as well.
    • Aug 30 2009 | 7:49 pm
      pscl - What kind of computer are you running?
      This problem is interesting/frustrating because it seems be a lot of different things that are causing it. For a while I had a problem where I couldn't play sound in ANY application without problems within 5 minutes. It turned out to be due to internet sharing over ethernet being enabled. I was sharing my Airport connection with a PC that had no WIFI. Someone posted a solution on the apple forum that fit my description.
      Now the triggers of this problem is much more intermittent and hard to track down, with this rewire/max thing being one of them.
      Ultimately I think there is a fundamental underlying issue that all of these things are triggering and I suspect it is the firewire bus on my MBP and not the MOTU. The reason being is that eliminating some of these OS functions like the sharing I mentioned seem to fix the problem. When connecting my MOTU to my PC for testing, I haven't had any problems.
      I'm not sure this forum is the best place for it, since this may not be a Max 5 issue, but I'm glad (sort of) to see that my problem isn't completely isolated. If more people are having issues, there is more chance for a fix. :
    • Aug 30 2009 | 11:11 pm
      I'm using my old PowerBookG4(powerPC)1.33GHz. Not much RAM (one bracket died..etc.)
      Now that you say it, I might have this problem since my new high speed internet connection is in. My roommate(PC) and me are using my Airport router. Maybe realplayer... Thanks for the answer! pascl
    • Aug 31 2009 | 2:46 am
      Well in this situation, there is an Airport Express. My macbook pro was connected to the airport over wifi. My pc was connected to my macbook pro via an ethernet cable. I set up internet sharing so my PC could connect to the internet over the ethernet cable. Unless you are doing the same thing (you would know for sure that you are), this problem doesn't apply to you.
    • Aug 31 2009 | 7:17 am
      pscl wrote on Sun, 30 August 2009 20:07 (nothing comes out/or high pitches)
      this is a known rare bug of the 828mk2. The trick out is to quit max, to go in the MOTU Audio Setup software, to turn the ADAT ports off and on again, then voilà! Sorted!
      It seem that the 828 decides that this port is active and does not tell the driver...
      I've already documented this on this list somewhere
    • Aug 31 2009 | 12:51 pm
      THANKS!!!! It works! - - - VERY good to know indeeed!
      Funny. That had never happend to me... after four years with the same set up!
      (Sorry for not having look carefully enough in the archives!) Have a nice week maxers. pascl
    • Aug 31 2009 | 1:33 pm
      I've gone over that issue with support. It does seem to solve the problem, except I have to shut everything down and back again. In certain situations (such as when using Max with Rewire) this can happen every five minutes.
      Shutting down and flipping the ADAT switch every five minutes really isn't a viable option.
      That being said, I just upgraded to OSX 10.6 and will be doing some tests today to see if the problem persists.
    • Aug 31 2009 | 5:57 pm
      pscl wrote on Mon, 31 August 2009 13:51Funny. That had never happend to me... after four years with the same set up!
      It happen to me only once, after many years of happy ownership and many years ago... but it had to be on the London premiere of my 50-minute drum suite, where I was the main feature... we did 4 false starts, then I remembered vaguely reading about this months before, tried it and saved the gig (and my honour
      Otherwise, MOTU is dead reliable for me (I have 828 mk1 and mk2, and the uni has many other instances of both versions and they work flawlessly.)
    • Aug 31 2009 | 7:16 pm
      pscl Funny. That had never happend to me... after four years with the same set up!
      normaly the high pitch dropout should happen every time you attach a new DVD burner to the motu, or even when turning a new harddrive on, at least when it is behind the motu.