Max crashing with every save in Max for Live

    Nov 26 2009 | 3:22 pm
    Every time I save the patch I'm working on in Max for Live, Max crashes and I have to restart. Anyone else experiencing this?

    • Nov 26 2009 | 3:42 pm
      Does it crash no matter what you save or does it crash when saving this particular patch?
    • Dec 01 2009 | 9:36 pm
      same here. It just crashes every time I save.
    • Dec 01 2009 | 9:44 pm
      Hi Guys,
      Everyone with crashing on save or any crashing problems please send full details into
      We'd like to see the patch it's crashing with if there is one in particular, and include all details of your system, OS,CPU, RAM, Max version, Live version, anything you can think of that might help us get you going. If you can get us crash reports and Live logs that would be cool too.
    • Dec 01 2009 | 11:09 pm
      ok I just sent the report that osx generates. How do I get the Live log ?
    • Dec 02 2009 | 12:16 am
      Log.txt is in the Ableton folder in your user Preferences on Mac.
    • Dec 25 2009 | 1:43 pm
      I have the same problem. Would be nice of you guys to share the secret...
    • Dec 25 2009 | 1:56 pm
      Jist re-installed live and it didn't help. What's also annoying, that the umenu doesn't work when I close the patch window. The umenu serves as a menu for MIDI ins. Check the video:
    • Dec 29 2009 | 7:03 pm
      Same problem, it crashes on every patch i try to save. I send a detailed report.
    • Oct 07 2010 | 8:14 am
      Someone resolve this problem? Please tell me how. Ableton Live crash every time I try to open Max for Live
    • Oct 07 2010 | 8:34 am
      The best thing to do is to contact cycling's tech support (see the email address above). You can alos try to reinstall both Max and Ableton Live.
    • Oct 10 2010 | 1:22 pm
      yes, i think i try to reinstall both m4l, and live. mine is crashing every time i try to open m4l. it worked fine when i tried the demoverson, but not after i purchased it.
    • Oct 10 2010 | 2:53 pm
      Do you open M4L before ? or it is when you open a specific patch ?
      I have had the same trouble when I build my translator MAX5 --> ZIP I saved my patch and then when I open it later MAX crash immediately. On another older version I could open but I couldn t save anymore without a crash I couldn't work anymore on my product. As it was hours of job, I take a look to get my patch back. All the problem come from a UMENU that I was using for midi list of device. I don't know how, but the UMENU was saved with wrong text parameters with wrong ascii codes (more than 127 I suspect) Perhaps because I disconnect midi and ask again for the list...and then I saved the patch...
      To solve the problem : I open the patch as text and I fix the bug directly on all UMENU object After, the patch open again for the one that crash MAX, and the other one I was able to save again without crashing.
      with the search option research "umenu", search for the object
      "maxclass" : "umenu", "fontsize" : 9.0, "outlettype" : [ "int", "", "" ], "patching_rect" : [ 34.0, 203.0, 171.0, 17.0 ], "items" : [ "Microsoft Synthesizer", ",", "SynthÈ. SW table de sons GS Mic", ",", "1:EDIROL UM-2 MIDI 1", ",", "1:EDIROL UM-2 MIDI 2" ],
      have a look on the "items" line, if you see wrong characters, you have find the reason why max crash. this patch can't be opened without crashing max if the line is with wrong asccii codes. (search in all the patch, perhaps other objects do the same problem)
      to solve this, you must replace your "items" line by a good one. Be carefull, if the new "items" line you put is not correct, all the next object won't appear on your patch. (but without crashing)
      the best solution is to find another patch with the object in the same context. Save it as text, and copy the good line to put it
      good luck I hope for you it is the same problem
    • Oct 10 2010 | 4:06 pm
      thanks anyway. i hope your solution works for some, but my ableton live crash whenever i try to open m4l. even if its just a standard m4l plugin. both ableton live, and my max/msp, works just fine, but the m4l wont work