Max hangs on startup / osx 10.8

    Oct 30 2012 | 3:13 pm
    Hi, I've never used max-msp before but I'm trying to get it up and running for a collaboration I am working on. I first downloaded the newest max 6 demo and ran the "mxf" file from my collaborator. Everything started up fine on both Max 6 and Max 6 Runtime. An hour later I tried to open Max again and this time it wont open, Max Runtime wont open either. It just hangs on startup, it doesn't crash I just get the "Application not responding" in Activity Monitor.
    To fix the problem I tried the following: restarting my machine, uninstalling (deleting the folder in Applications AND the Cycling74 Library folder) and reinstalling Max 6 , installing Max 5, repairing permissions, installing Max as a different user. Nothing. Max simply will not open.
    I can find no clue to the problem causing this. I have tried simply opening one of the example patches, or just opening the application by itself. Max will not start.
    I'm on a new macbook pro on OSX 10.8, java version "1.6.0_35" is installed.
    Any help is much appreciated

    • Oct 30 2012 | 5:36 pm
      update: my collaborator sent me the patch in standalone form which also is hanging at startup....
    • Oct 30 2012 | 9:00 pm
      Ok i fixed the problem, I opened and took a look at the output when Max was trying to start. It was giving errors about an incompatible MIDI Driver, so I deleted some old drivers located in my midi drivers folder ( /Library/Audio/MIDI Drivers/ ) and then it started up immediately.
      For reference here is the output I was getting in Console, maybe it will be useful to someone in the future:
      10/30/12 9:18:13.567 PM[143]: ([0x0-0xc90c9][1318]) Exited: Terminated: 15 10/30/12 9:18:14.380 PM spindump[1325]: Saved hang report for thirdminda version 5.1.8 (45300) (5.1.8) to /Library/Logs/DiagnosticReports/thirdminda_2012-10-30-211814_Eriks-MacBook-Pro-4.hang 10/30/12 9:18:21.686 PM MIDIServer[1333]: MIDIServer [1333] starting; arch=x86_64 10/30/12 9:18:21.690 PM MIDIServer[1333]: PlugIn EmagicUSBMIDIDriver.plugin -- file://localhost/Library/Audio/MIDI%20Drivers/ does not contain a supported architecture. 10/30/12 9:18:21.690 PM MIDIServer[1333]: MIDIServer relaunching because a 32-bit driver was found 10/30/12 9:18:21.699 PM MIDIServer[1333]: MIDIServer [1333] starting; arch=i386 10/30/12 9:18:21.849 PM[143]: ([1333]) Job appears to have crashed: Abort trap: 6 10/30/12 9:18:21.849 PM[143]: ( Throttling respawn: Will start in 10 seconds 10/30/12 9:18:21.882 PM ReportCrash[1312]: Saved crash report for MIDIServer[1333] version 78.2 to /Users/erikwp/Library/Logs/DiagnosticReports/MIDIServer_2012-10-30-211821_Eriks-MacBook-Pro-4.crash 10/30/12 9:18:21.885 PM ReportCrash[1312]: Removing excessive log: file://localhost/Users/erikwp/Library/Logs/DiagnosticReports/MIDIServer_2012-10-30-211458_Eriks-MacBook-Pro-4.crash
    • Nov 04 2012 | 5:25 pm
      Looks like you needs to update your MIDI drivers: PlugIn EmagicUSBMIDIDriver.plugin -- file://localhost/Library/Audio/MIDI%20Drivers/ does not contain a supported architecture.