Max Runtime 32-bit on windows 8.1 - issues


    Nov 07 2013 | 7:23 pm
    Hi,
    I've sent a collaborator who doesn't own Max a patch to run for a presentation, but he's having trouble getting 32-bit Max 6.1.5 Runtime to work properly on his 64-bit Windows 8.1 laptop (64-bit Max doesn't have the jit.qt.movie features we need implemented yet).
    I don't know the details of his problems yet, but has anyone else had success or failure running the 32-bit Mac Runtime on 64-bit Windows 8.1? Any pointers?
    Thanks!

    • Nov 07 2013 | 8:01 pm
      More details: he gets this error when trying to open 32-bit max runtime: Faulting application name: MaxRT.exe, version: 6.1.5.7552, time stamp: 0x52713145 Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000 Exception code: 0xc00001a5 Fault offset: 0x05a07bbb Faulting process id: 0x1984 Faulting application start time: 0x01cedbeed5cd510a Faulting application path: C:\Program Files (x86)\Cycling '74\Max Runtime 6.1\MaxRT.exe Faulting module path: unknown Report Id: 13b82a2e-47e2-11e3-be9a-008cfa66aa24 and says he's tried various compatibility modes as well, to no avail.
    • Nov 08 2013 | 8:35 pm
      Just to follow up - it seems that he can run Max (in demo mode), but not max runtime or the max runtime .exe included with max.
    • Nov 08 2013 | 9:43 pm
      Weird.
      The runtimes are working fine in 8.1 for us.
      If you install debugview
      You'll be able to view Max's startup sequence on Windows - perhaps there will be a clue in there somewhere
      Cheers
      -A
    • Nov 12 2013 | 3:19 pm
      from my colleague: "Well, I downloaded DebugView as suggested, tried to open Max Runtime (32-bit), and looked at the last start call in the log. The last call was ad_load. My guess is that this is the process that loads all the externals in the folder "ad", such as ad_asio.mxe, ad_rewire.mxe, ad_mme.mxe, etc. And I suppose this is the process that is crashing MaxRT before it even gets to the opening splash screen. "
      For me on XP 32-bit, I get path_buildcache right after ad_load. Maybe there is actually something wrong with that on his end...
      ... [2956] startup call: ad_load [2956] startup call: path_buildcache ...