Max startup time


    May 15 2009 | 9:27 am
    Hi all.
    I have question regarding max startup time. Om my quad core Xp machine Max takes a very long time to start up. 3 - 5 minutes is not uncommon.
    I have had similar experiences on several windows machines both with max 4.6 and 5.xx what gives? I suspect the dreaded ilok dongle, but if anybody has any suggestions as to how I can rectify this issue please enlighten me.
    All the best Thor

    • May 15 2009 | 2:27 pm
      Have you tried 5.0.7? It starts up much more quickly, now. I was experiencing super slow start times prior to this version, as well... Still not the fastest app to start but vastly better than anything prior to 5.0.7.
    • May 15 2009 | 2:37 pm
      Max 5 should startup faster than max 4 did. It no longer loads all UI objects at start.
      The biggest factor in regard to startup time is how much stuff you have in your max search path. You might try removing all non-standard things from your search path just to see if that helps. If so, then examine what you really need to have in your max search path.
      Rob
    • Aug 27 2009 | 12:46 pm
      ...and check on one more thing I noticed yesterday:
      When Max5 took about 5 minutes to start, I noticed in the Activity Monitor that also syslogd was using 30% CPU, and indeed, in the Console under system.log, there were about 200000 (yes, two hundred thousand!) lines like this:
      Aug 26 22:45:23 IMTR-1646-Schwarz-4 [0x0-0x18018].com.cycling74.MaxMSP[153]: vst_audiomaster 7 Aug 26 22:45:23 IMTR-1646-Schwarz-4 [0x0-0x18018].com.cycling74.MaxMSP[153]: vst_audiomaster 4 Aug 26 22:53:20: --- last message repeated 1 time ---
      Now what does that mean?
      (Incidentally, all Max console messages get logged to syslog also (twice, it seems), which would be great for debugging, if someone had told us...)
    • Aug 27 2009 | 1:41 pm
      sounds like it could be a similar issue as the last max update . it was fixed at the time by a replacement vst external
      here's the old post