Max6 not autocompleting object names in my library

    Oct 31 2011 | 2:12 pm
    I added my own library into the search path (main search path, not project search path) and tried to insert an object but as I typed, Max 6 did not offer to autocomplete the object name. I thought it might be that the search path would not kick in unless I restarted but that didn't work either.
    This works fine in Max5 (although I still have to quit/restart if I change a path)

    • Oct 31 2011 | 4:23 pm
      Hmmm, I am now observing that autocomplete works intermittently. Very strange.
    • Nov 01 2011 | 8:51 pm
      Yeah, I'm experiencing some probleme as well with the object box autocompletion. I quit and restart max6,it still doesn't work (and sure the objetc box autocompletion is enable in the preference). This problem started this afternoon, I was coding in max 6 with a max5 standalone running. I just quited max (5 and 6), restarted Max 6 and it works. But this time it doesn't work anymore.
    • Nov 01 2011 | 9:29 pm
      I believe that you need to wait for the database to finish building. If you wait 30-60 seconds from first launch (or longer if your search path is huge), does it then work for you?
      We can work on optimizing this initial delay, but it would be good to confirm what you are experiencing is not something else.
      In general, with the new project implementation, hopefully you can streamline your search path for performance improvements in general.
    • Nov 01 2011 | 9:58 pm
      Yeah, I knew we can have this kind of delay before database finish building and autocompletion come back, but here it's was really not this : I worked around 30 minutes and the autocompletion never came back.
      But I found a solution, thanks to Andrew Pask's answer about the Benchamrk-example-msp patch crashes I had last night : So I just delated my Preferences files (c:Users[Your username]AppDataRoamingCycling'74 Please note that "AppData" is an invisible folder and may need to be made viewable), Restart max, autocompletion was back! Cheers, A.
    • Nov 01 2011 | 11:17 pm
      Hmmm, when I first ran into this, I was actually trying to use the project search folder and when that didn't work, I figured it was a bug and just switched to the global search path. But it's not a question of an initial delay --- I've had this happen to me even after Max has been running for some time.
      I'm on a Mac, not Windows, so not clear what I should delete to fix this.
      Also, if I add a search path while Max is running, it seems to me that Max should be able to find stuff there without having to restart Max. I'd be willing to wait for a synchronous update after adding a new search path. I just reinstalled Max6, started it up, added my library to the path and waited several minutes but I still don't get any auto-completion. However (and I noticed this with Max 5 as well), if I try to add a second instance of the same object, then autocomplete works. However, it still does not find other objects until I use them once. As I write this, I'm quitting and restarting, waiting a couple of minutes.....
      (doing some email)
      ....10 minutes later ....just tried instantiating one of existing objects and no auto-completion.
      Also, now that I know that Max is doing a database update, I'm wondering when exactly it does this. For example, I often create abstractions and save them into a folder that is in the search path but when I then try to use the abstraction, I don't get auto-complete for it either (although maybe that's just related to the more general issue)
    • Nov 06 2011 | 6:42 pm
      When I click on the "Patchers" section of the object explorer and use the filter, the patches of interest to me in my own library show up with no problem.
      However, autocomplete still does not work for those objects, even though Max 6 has been open on my laptop for the last two hours.
    • Dec 28 2013 | 5:17 pm
      Was this ever resolved? Have the same problem (in Max4Live). I have added the path to my subpatches directory, I can see the patches in the explorer, and if I type the name correctly, they load OK, so, the paths seem OK. But when typing, auto-complete doesn't find them...
    • Apr 02 2014 | 12:02 pm
      It seems that it is not resolved yet, since I also have this issue. I added a my own package (under Max/packages), I see my new patches in the object explorer, but autocomplete doesn't work
    • Apr 02 2014 | 5:42 pm
      Same here (intermittent). MBP 2x2.4 ghz dec 2012 OSX 10.8.5 Max 6.1.6 Live 9.1.1.