Max/MSP doesn't work with Atom Intel processors


    Jan 08 2010 | 1:44 pm
    ...if it does, please let me know. Tested on different netbooks, all running Windows XP Home Edition : you simply can't launch Max (the max.exe process ends after a few seconds). According to Cycling74, whom I asked if these computers might work, the answer was yes. When you read more about it, you find that Max doesn't work with some processors (though max runtime works well). This is because of their copy protection system (interlok). Nice ! In order to avoid piracy, you find yourself unable to launch a program you honestly bought a few hundred bucks...
    Thanks, cycling74

    • Jan 08 2010 | 2:16 pm
      This iLok code is not code from cycling74. It is from interlok, and I would bet that a note to them, rather than bothering the client *who is suffering (*with* you) *their* lack of compatibility* would be a better effort. Don't think that C74 was aware of this, eh? (they said as much to you) And yet you blame *them*...
      Just think: how new is this processor? How much software in the multimedia field *is* fully verified to run on it? You are mad at the wrong people, and from the evidence of this note, do not have the correct attitude to be using cutting edge hardware. Relax, contact the *correct* developers, and hope for the best.
      Sheesh. DrB aka j2k
    • Jan 08 2010 | 5:55 pm
      MAX 5 works fine here on my Samsung NC10 netbook - I don't use iLok though...
      Don
    • Jan 08 2010 | 9:05 pm
      Just a note, we have no indication that computers with Atom processors will not run Max. Until we find otherwise, I believe the issue that saturnin79 is experiencing is something completely unrelated, and being handled in Support.
      -Ben
    • Jan 09 2010 | 1:38 pm
      Max5 Runtime fires up fine on an MSI Wind (N270-based), although the box has no MIDI or audio drivers so I don't know if it'll do anything useful. I've not tried the "real" Max.
      @Charles: in my opinion, the responsibility here does lie with Cycling '74. I'm a Max customer, not a PACE customer, so I don't see why PACE would pay me any particular attention. Cycling have licenced PACE AP for Max, and if the Atom is a supported platform then it's up to them to lean on their sub-licensers whose code they are using. IMHO, of course.
    • Jan 09 2010 | 4:29 pm
      Perhaps you're right, but *if* this was the case, i'm sure C74 would confess it...I just wonder why the complaint was put into a forum, rather than just handled through support email? Public trashing of any development effort bothers me when we as users often know next to nothing of the real issues... I felt that if the fellow had knowledge of it being the Pace driver and/or ilok key, why did s/he come and start a whole new forum topic in the c74 public forums? And not as inquiry, but as loud complaint?! the response from c74 leads me to believe that there was on-going support triage: a complaint like that, so often based in incorrect knowledge, can be so damning to a small company... often with no real cause: it was a misunderstood install procedure, it was a download of the wrong binary type (32 v 64), etc.: silly stuff. And in my experience, if there is genuine evidence of a problem , c74 will both work to get it solved, and be the first to acknowlege it's existence.
      Having not heard from c74, I kinda doubt there is much to this as a confirmed incompatibility...of course, I could be wrong, it's happened before. pax cfb aka j2k
      PS: & Yeah, I was really still angry @ a totally unrelated business analyst. "But, why *didn't* you read my mind, charlie!?" .. i think i really need more time w/ music & less with profit makers. As if I have a choice :0).
    • Jan 14 2010 | 6:15 pm
      Hi everyone,
      I must apologize - and MUST thank the Cycling74 Support Team. It know does work, as fine as Max can work on these little netbooks. Why did I post this on this forum, instead of just asking for help and contact the support team, i don't konw, i was angry. In fact, i paid for Max, which is alright, it deserves it. But it looked like the hassle really came from their PACE protection system, and i'm sick of paying part of the price of any software to help companies build stuff against piracy acts. The whole story is here : (hope i won't go to jail as i'm telling this). I searched & found a shitty cracked exe on the net, which I tried and... Max DID run. Of course i dropped this in the can, did a clean re-install of my system, but once again, i got more and more hassled by this system protection, and, please tell me why I, me, personnaly got to be hassled as I paid for Max ???
      Now comes the great thing : Cycling74's support team is great and they got me Max working. I'm pasting the clue, may it help (or not, if i'm dummy enough not to have tried this my way before) :
      Hi Jean-Pierre,
      I'd like for you to try one more thing and verify the DEP settings on your computer. DEP should be set to its default of "Turn on DEP for essential Windows programs and services only."
      1) Click "Start" 2) Select "Settings Control Panel > System and Maintenance 3) Select "System" 4) Click the "Advanced" tab 5) In the "Performance" region select "Settings" 6) Click the "Data Execution Prevention" tab in the dialog box 7) Select "Turn on DEP for essential Windows programs and services only" 8) Click "OK" 9) Reboot your system.
      Let me know if this affects things at all.
      All the best, -Ben
      Thanks, Ben. Thanks a lot. All apologizes