MAX/MSP + Oxygen 25 - Communication problem

    Sep 11 2011 | 5:23 pm
    I’m trying to setup my M-Audio Oxygen 25 midi keyboard to work with Max as a cotroller. I’m using the midiin with midiparse to retreive the control information in order to map them with what I need to control.
    The problem is that the keyboard responds very impredictibly. Some times gives information by pressing a key or turning a knob, other it doesn’t respond or it responds with inconsistent messages (like changing between two cotroller numbers when using the same knob).
    Please help!

    • Sep 11 2011 | 6:06 pm
      Hi have you tried using just [notein] and [ctlin]?
      [midiin] and [midiparse] always seems to me to be a little unwieldy or heavy-handed - unless one needs more than just notes and controllers.
    • Sep 11 2011 | 8:38 pm
      [midiin] and [midiparse] work wonderfully well. I've been building a complete replacement for MainStage and those objects are core. You generally need aftertouch and pitchbend as well.
      If the keyboard seems to be misbehaving, I'd suggest running a MIDI monitor to make sure that it is producing what you expect.
    • Sep 11 2011 | 9:59 pm
      I think the OP needs to post a patch first, before we discuss pitchbend and aftertouch, as these issue were not mentioned. The 1st rule of trouble-shooting is: start simple - which is why I suggested [notein] and [ctlin].
    • Sep 11 2011 | 10:19 pm
      It is precisely because one should 'start simple' that I suggested running a MIDI monitor.
      If the keyboard seems to be "behaving unpredictably", I think it would be better to first eliminate the keyboard and connection into the computer as a possible problem source, something that can be done trivially with a MIDI monitor such as the free app (assuming it's a Mac, I'm sure there are similar tools for Windows). Then you KNOW the problem is with the Max patcher.
      Of course a patch will help --- it may turn out to be something as trivial as not unpacking the data coming out of midiparse but I'd still want to eliminate external issues first.
    • Sep 13 2011 | 5:55 pm
      I have used the Oxygen 25 the silver one and the black one that only has USB (no midiport) and both work fine with midiin and midiparse so I think it is either your patch, your connection, your MIDI settings or you keyboard but it does work.
      I had a problem with the black one where you can't send MIDI out to it as it does not have a MIDI out. So it was causing some kind of MIDI feedback in M4L - I disabled sending MIDI out to the device in Live's prefs and it was fine - it might be that I have seen it a few times with people.
    • Sep 13 2011 | 9:41 pm
      I've got the newer (charcoal gray) Oxygen 25 and have the same problem. I have found that unplugging and replugging the USB cable to the keyboard seems to do the trick. There seems to be some issue with the O25 that the computer "forgets" that it is connected if a MIDI program isn't running.
    • Sep 14 2011 | 10:19 am
      Oh! Thanx for the immediate responses. So, I first did some MIDI monitoring to check my Oxygen’s reactions and it performed perfectly. Then a strange thing happened. I opened MAX and tried the notein object. It started again responding in a strange manner, it was responding only sometimes I was pushing a key, and other times it was giving the following message (in Midi Monitor):
      22:45:54.589 From Oxygen 25 Invalid 3 bytes
      I’m sure now, there is something wrong caused by MAX and in particular with the midi family objects.
      I tried throwing away the MAX folder and installing the latest version (5.1.9).
      Still no result...
    • Oct 15 2011 | 5:51 pm
      Just wondering if you ever found a resolution to this. I've created a little demonstration that shows the problem pretty clearly. I'd be curious to know if others using the Oxygen 25 have the same problem. I have the newer (charcoal gray) Oxygen 25 and unless I unplug and replug the USB cable (sometimes 2-3 times), the O25 doesn't transmit properly. I've tried it through a powered USB hub, and directly into my MacBook Pro (OS 10.6.8) with the same result.
      For M-Audio Oxygen 25 users:
    • Oct 15 2011 | 7:21 pm
      I also just tried using the MIDItester from the "Extras" menu. If I just launch the MIDItester without actually selecting an input device, I get all the appropriate messages from my Oxygen 25. However, if I selecte the Oxygen 25 from the input device menu, it stops working.
      I've read several forums about a problem where the Oxygen 25 stops working if it receives MIDI messages from the software, but I'm not sending any data to the O25. I've also tried disabling the MIDI output in the MIDI setup window, but that doesn't seem to make a difference.
    • Oct 16 2011 | 5:25 am
      Well, the good news--at least from a Max perspective--is that it seems to be unrelated to MaxMSP. I have the same problem with all my MIDI apps and the Oxygen 25. There seems to be some issue where the Oxygen 25 gets discombobulated from the computer when a MIDI app is not running. The bad news is that I have a computer lab with 20 Oxygen 25s and a bunch of them are exhibiting this behavior.
    • Nov 17 2011 | 1:06 am
      Unfortunately I realized that the problem is global. Sibelius also responds arbitrarily with my Oxygen 25. Still no solution...
    • Nov 17 2011 | 1:16 am
      M-Audio officially states that they DO NOT SUPPORT THE MAC OS X 10.6.8 update with Oxygen 25 !
      Still researching on the issue...
    • Nov 17 2011 | 1:10 pm
      No solution found. Enough time spend. Mac OSX is causing a bunch of problems to other programs also. Going back to Mac OSX 10.6.7.
    • Nov 22 2011 | 1:58 am
      Ok, I'm sure now the problem is the MAC os X version. I'm running 10.6.7 and everything is fine!