MAXSDK CYGWIN setup issue

    Jul 06 2011 | 8:12 am
    Hello all! I'm trying to get started and am running into to some initial road blocks (following instructions at
    I have the latest CYGWIN installed with the proper packages included. I have managed to get to the minimum project directory (its been a while since I UNIXed, but am glad to be back). When I tried STEP 1, I get the following error:
    gcc: The -mno-cygwin flag has been removed; use a mingw-targeted cross compiler.
    Any help would be much appreciated

    • Jul 06 2011 | 6:25 pm
      What version of GCC are you using? I'm guessing GCC 4 because that no longer supports the -mno-cygwin flag. I've only just started messing with the SDK myself, but I believe if you want to use Cygwin you have to use GCC 3 which is still available in Cygwin, I compiled my first external last night using this, though I havent tested it yet.
      I also found a note explaining how to use GCC 4 with Msys/Mingw which is located in MaxSDK-5.1.7examplescollectCompilingWithGCC.txt although I havent tried this yet.
    • Jul 07 2011 | 4:53 am
      Thanks comfy, I was not aware of that. It was a little bit hard to locate that file because both the links on the downloaded guide and online are incorrect/broken.
      Have you had any luck? I just gave it a quick read and am going to try it tomorrow.
    • Jul 08 2011 | 4:47 am
      Taking a look at that file a little more reminds me of all the Getting Started guides (I'm trying to setup a VST SDK as well) I've looked at in the past week. They assume I have more experience with the setting up something like this than I actually do.
      I know how to program C++ in a unix environment, but I've never had to set one up. So I'm running into walls very often because of those assumptions and because some guides seem to be erroneous with respect to which file/directory to work in (see below), probably because they are copied from older versions without a thorough check.
      (my above rant is not directed at any particular or group of developers; I am just getting over some frustrations; I know there are some necessary hurdles to get over, and that I will be fine if I simply keep trudging onward)
      That said, I would like to discuss my progress.
      comfy: After going through the text file several times, I finally am beginning to get this whole set up business. I do have some questions about it though: what is with Step 3 in the Environment Set Up part? I get what fstab is for, but does it need to be copied, and what other Mount-points should I be adding? Also, I don't have Perl, but I am guessing that's just an example. Finally, I couldn't find that full version of MinGW, why is that version that must be installed?
      So I was not ready to go through with it, so I began to research -mno-cygwin. I eventually made it to, and after noticing that "simplemax.c" was in another dir, I realized that was what you were trying to tell me all along. It worked, but I was a little bummed to see that the xpatch did not do much.
      Anyways, I want to set up an environment in Eclipse, which I have also been getting the hang of. So I will make a new post as needed when I get that going. I am unsure of whether to stick with the Cygwin using gcc-3 and risk things not working the way I expect in the future, and trying MinGW out. Any suggestions or experience with either of these two in Eclipse for Max dev would be most appreciated
    • Jul 08 2011 | 10:12 am
      Eclipse for C/C++ with MinGW seems to work OK. I've compiled some of the examples and they seem to work, although I havent tried debuggin yet. I had Eclipse/MinGW allready installed before I started messing with the SDK so I went with that. If you install MinGW in its default location, Eclipse will find it, so no need to set any PATH variables. You have to obviously set up you project settings etc. I just made a default project with the correct settings which I just copy and rename, and then add the source, def, and helpfile from the SDK and build it. If you wanna try this and get stuck I could always zip up one of the projects with the settings allready set up.
    • Jul 08 2011 | 8:23 pm
      Cool, I would appreciate that, at very least for reference. I've only now just started to get the Eclipse CDT going with their tutorials, but I hit some road bumps there too, and I suspect have something wrong in that setup: Maybe you could spot what's wrong. Either way, thanks again.
    • Jul 09 2011 | 1:13 am
      Might be worth getting Eclipse working right first with the 'hello world' example. I had a look at your posts and I'm afraid I cannot help. Could try uninstalling MinGW (making sure the old installation folder is deleted, I had to do this manually) then re-installing MinGW (Install everything), and perhaps get the latest version of eclipse. I cannot say Ive had any problems like that, eclipse seemed to work right first time, I didnt have to set any path variables at all (though I am on old faithful XP). Im no expert but perhaps its getting confused with some other PATH variables you have set up, maybe from cygwin