Maxuino problems

    Feb 12 2013 | 12:07 pm
    Hi All, I am experiencing some difficulties with getting Maxuino to work with my Arduino Mega. I have opened up the patch to try and get myself started, however I am unable to make any meaningful communication with the Arduino happen. The Rx light flashes to show that there is some degree of connectivity, however I am unable to do even simple things like flash pin 13. When I open up the Maxuino GUI as a standalone patch I experience the same difficulties. Does anyone have any ideas? Thanks Luke

    • Feb 12 2013 | 1:31 pm
      Hi i had the same problems, try downloading version 007, (you can get it off the site) its far better laid out and worked almost straight away for me!
      I spent ages trying to get that new one to work with no joy and i got servos and the lot running in less then an hour on the old version!
      try it and if you cant get it going let me know, i can prob send you a working example when i get home.
    • Feb 12 2013 | 2:55 pm
      Hi Oli, Thanks for your reply! Weirdly I was using the older version which you mentioned before, with success, but now I get this message in the max window;
      [arduino]_WARNING_currently_unsupported: 160 [arduino]_WARNING_currently_unsupported: 176
      Also the same problem as before with the Rx light flashing but no flashing light on pin 13 when i attempt to turn it on and off.
    • Feb 12 2013 | 2:59 pm
      Hi Oli, I have absolutely no idea why it is working now, but it is! For both the old and the new maxuino patches. I played around with re-uploading the old and then the new standard firmata into the Arduino. Eventually it just all seemed to work as it should (with the standard firmata). Really weird and beyond my limited knowledge as to why this might be the case, so sorry to anybody who has the same problem and is looking for a solution. Anyway thank you very much for your help Oli! thanks Luke
      P.s. One thing I have noticed with the newer maxuino, is that the Arduino will sometimes freeze the first time you try to communicate with it, also that the serial port is not selected automatically, so you have to select something else from the list and then go back to the usb connection to actually select the Arduino. I really don't trust it at the moment, so may go back to the early patch as you suggested!
    • Feb 12 2013 | 3:04 pm
      You could maybe try contacting on of the developers, i think his name is coleman? (his name is on the patches anyway) I have e-mailled him before and he was very helpful. i cant check my maxuino version due to being at work, but i cant see why it would not work, i had mine working approximately 2 weeks ago with a arduino uno.
      Good luck,
    • Feb 12 2013 | 3:05 pm
      lol missed your post!
      glad its working.....used the old 'shut everything down and start again' technique!
    • Feb 12 2013 | 3:07 pm
      Haha! Yep! just start shaking the laptop and screaming threat until it works ;). Cheers man!
    • Oct 26 2013 | 4:30 pm
      Hi All,
      just started to get Maxuino with an Arduino Mega 2560 runnin´. I downloaded the maxuino_b016.
      Test LED works.
      But I have the following messages in my MAx window:
      js: can't find file maxuino.TSL2561.js js: can't find file maxuino.TSL2561.js newobj: ali.front: No such object
      js: *** WARNING ***: For pin 13 Firmata reports this as an invalid pinMode.
      I didn´t find anything called maxuino.TSL2561.js ?
      I´m pretty overchallenged with this.
      Looking forward for answers :)
    • Oct 28 2013 | 6:29 pm
      I'm also having the same problem. with Maxuino_b016. It worked fine last week, but since updating to the new mac operating system I get the message:
      js: can't find file maxuino.TSL2561.js
      Not sure what's going on. Any help would be greatly appreciated, thanks!
    • Dec 08 2013 | 10:50 pm
      I also have: "js: can’t find file maxuino.TSL2561.js" in the max window, on windows xp 64bit, 32bit max
      i can make maxuino work, however, but when leaving max and maxuino running I sometimes come back to the machine and find the whole pacth frozen.
      To make it all work again I have to try hard to close max, then many times need to shut down the OS and restart (as,well disconnecting the usb and reconnecting at that time) : /
    • Dec 10 2013 | 4:40 am
      for those interested in the future,
      the new versions of maxuino were not stable on ethier of my 64 bit or 32 bit windows xp.
      I had use an older version: maxuino 09
      I used arduino 022 forthe arduino drivers
      and used the arduno.exe software 022 to upload the standard firmata found in the examples in the 022 file menu.
      Also you need to point max in the right direction for maxuino 09
      max > options > file preferences > then click bottom left "+" symbol and point to the maxuino 09 folder
      you may need to flick between COM ports with maxuino to wake it up at start up. you can make a small subpatch to do that if you need to.
      best thing to do is test it out in the maxuino examples folder
      open up: maxuino-example-GUI.maxpatch.
    • Dec 11 2013 | 2:42 am
      another tip to reduce crashes! Clogging up of max type crashes.
      I just added (speedlim) to the analog inputs ( which are output into max) this reduces the amount of data flowing into max.
      i've had maxuino 9 running now for over 2 hours. It has not froze max yet. where as before it was clogging up with a slugish response. I suppose it depends on what you do with your input data but it seems if you are processing the analog input data you may need to slow the rate down first. Even if your cpu is 'not' taxed , there is something else about max? perhaps the scheduler or something that becomes clogged, well before the cpu gives warning?
      there are two that are very helpful objects for reducing data rate flow (js speedlimit.jso) and there is (speedlim) both are worth checking out.
      now i know what the problem was, it is likely that the newer maxuino versions will work in my patch too. But as 9 works o.k i'm sticking with it.
    • Dec 11 2013 | 7:45 am
      More and more fashion women’s clothes wholesale online and can you recognized which is better? Dear-Lover offer cheap clubwear, cheap dresses and cheap lingerie for women which are from China top sexy clothes manufacturer Shiying Sexy Lingerie Co., Ltd factory directly. It is the best choice for sexy clothes dealers and shopkeepers.
    • Dec 11 2013 | 3:49 pm
      I've found Maxuino 009 good as well. I find the serial object in Max very unreliable (maybe this is just when combined with Arduinos), and have often had to build in opening and closing of the port to my patches to make them more stable (eg. for installations).
      I recently moved towards using ethernet Arduinos with communication over OSC. Although you may have to write your own code (CNMAT's Oscuino is also a possibility), OSC greatly simplifies this. I've found using ethernet has made a huge difference to the stability of all my arduino projects; it has really elevated to a different level of reliability.