MIDI Input Problems

    Sep 08 2012 | 4:39 pm
    I'm brand new to Max.
    I'm having problems getting an input from my MIDI keyboard. I'm using an Alesis Q25. The device is recognised in the MIDI Setup window and both "input" and "output" are ticked. However, there doesn't seem to be any signal getting through. I created a midiin object (connected to Print) but when I press a note on the keyboard nothing happens.
    I'm sure that there's something really obvious that I'm missing, but I'm completely stumped! Any assistance would be much appreciated!!!

    • Sep 08 2012 | 5:17 pm
      Hi, and welcome to Maxworld
      have you identified which port argument to specify for the [midiin] object? Look in the helpfile for this object and you should be sorted.
    • Sep 12 2012 | 3:26 pm
      Thanks for your message, Brendan. Still no luck, unfortunately.
      In the helpfile for midiin, the device appears when I double click on the arguments (port) - i.e. it appears to be selected. But I'm still not managing to get any input. I tried the MIDItester as well, but again, no joy.
      I'm rapidly losing the will to live.....
      Any other advice would be greatly welcomed!!!
      Cheers, Ross
    • Sep 12 2012 | 4:00 pm
      Are you sure the OS receives the Q25 MIDI datas? Check with another software, like MIDI Monitor (http://www.snoize.com/MIDIMonitor/ , Mac only but I'm sure there are equivalent for PCs).
    • Sep 18 2012 | 9:44 am
      Thanks. I can get the Q25 (and other MIDI devices) working with Ableton. I downloaded a MIDI monitor, but really couldn't make any sense of it. Although, the device was certainly recognised.
      I can't understand why something as simple as trying to connect a MIDI device should be so difficult. Any MIDI device I connect is recognised by Max, but no input is occurring.
      I'm totally lost...
    • Sep 18 2012 | 6:58 pm
      Use this to select your input port, then play some notes on your controller. Do you see action with this?
    • Sep 19 2012 | 6:37 am
      Thanks Chris. Still nothing. Q25 appears in inputs and as an option in the outputs umenu, but nothing happens when I play any notes.
    • Nov 08 2012 | 11:17 am
      Hi guys, still struggling with this. It doesn't matter what kind of MIDI device I attach, it seems that there's no signal getting through - despite the device name appearing in a patch and in MIDI setup.
      To clarify: I'm running Max 6 on Windows. MIDI devices work with Ableton Live and Sibelius or any other programme, but not Max.
      Please help!!!!
      Cheers, Ross
    • Nov 28 2012 | 11:39 pm
      I think you should contact Cycling support.
    • Nov 29 2012 | 2:57 am
      Seems very strange... Have you tried scraping the Max 6 Preferences folder? Maybe something funky going in there. Shut down Max, then go to C:Documents and Settings(your account)Application DataCycling '74 and delete the Max 6 Preferences folder, then relaunch Max.
      If that doesn't help, I'd try a reinstall of Max next. Good luck!