midi objects - trying to send a port message

    Apr 16 2010 | 8:51 pm
    let me prepend this with: i have the latest update of max 5
    i am using some midi objects (noteout, ctlin etc) and one of the things you can do is double click on the object to select the midi port you want that specific object to listen to. you can do the same thing by sending the object a message "port [symbol]" whereas the symbol is the name of the port you want that object to listen to.... or so i thought.
    this is what the .maxhelp file says and the reference page but its not working. i've sent the message properly and it doesnt change that object's midi path.
    anyone else have the same issue???? any ideas for me setting up this patch without having to goto every one of my objects and changing them by hand????
    thanks GW

    • Apr 16 2010 | 9:27 pm
      If your port name has a space in it, you will have to slap quotes around the name. e.g. port "from MaxMSP 1"
    • Apr 16 2010 | 9:30 pm
      just tried that and as soon as i clicked off the message object the "" disappeared.
      But here's some good news: i figured a way around it. i used the object midiinfo to generate the list of possible midi devices and then did a send object to set the other midi object.
      but thanks for the help, although i still fell like this is a small bug that i hope the lovely people at cycling74 can fix on the next update
    • Apr 16 2010 | 9:32 pm
      to clarify i shouldn't have said "... midiinfo to generate the list..." because it doesn't generate a list it will however populate a umenu object from which to choose from.
    • Apr 16 2010 | 10:22 pm
      I can't explain why your quotes disappeared, it has always worked for me. I don't consider this a bug.
    • Apr 16 2010 | 11:21 pm
      Ohhhhh i see what happened, im an idiot. i wasn't spelling the device name properly, its case sensitive duh!!!
      sometimes staring at the computer screen for too long is bad for the brain.
      thanks so much for your help though!
    • Aug 26 2010 | 3:04 am
      Edit: nothing to see here, move along... sorry about that, I thought I had a ctlin port setting bug but I was kidding myself...