Mira 1.1.6

    Nov 11 2013 | 9:07 pm
    Hey everyone,
    Today I am overjoyed to announce Mira version 1.1.6. If you choose to update (and I very much recommend that you do) then you will need to download the updated Mira package, containing an update mira.frame, mira.motion and mira.multitouch.
    The new version contains small fixes for live.grid and some tweaks to the UI for iOS 7. Much more importantly, it also includes a subtle but massive improvement to networking that should address the biggest issues that people were having with the previous version 1.1.4. Finally, it is now possible to hide objects in Mira by setting the hide on lock attribute.
    As always, thank you for your continuing support and patience as we work to make Mira as fun as possible.
    Happy patching, -S

    • Nov 11 2013 | 9:51 pm
      Hello Sam
      Thanks very much for the update. I did not understand : does it concerns the package or the app itself? I'm asking because there's nothing new, for now, on the AppStore.
      Best Julien
    • Nov 12 2013 | 12:35 am
      Looks like there's a little bit of delay on the app store. We hope to have this sorted out by tomorrow. There is both new externals as well as a new Mira App. Thanks for your patience!
    • Nov 12 2013 | 2:55 am
      It's up now
    • Nov 12 2013 | 3:02 am
      It's actually up on the App Store but not on Cycling '74's website...
    • Nov 12 2013 | 7:52 am
      Again, apologies. Links are updated:
    • Nov 12 2013 | 8:21 am
      The connection problem is solved for me. Many thanks guys ! BTW, the umenu feature is quite amazing, when Mira opens… ;)
    • Nov 13 2013 | 2:14 pm
      Finally upgraded both Mira & Max, all works here EXCEPT i seem to have lost the goofy Mira icon on my ipad (it just appears as a boring white square now, i can live with that as long as the actual program works).
    • Nov 14 2013 | 10:35 pm
      Mr.Banshee words my words. Lost that cool icon on my ipad and just a boring white square. Running iOS5 on iPad first gen.
      Luis Aly
    • Nov 15 2013 | 11:32 am
      Ok, this is what I noticed with last Mira update (sofa): live.grid is not responding to touch on the iPad. Also it sometimes suddenly disappears from the iPad when changing settings with the inspector. This also happens to live.dial although less frequently. Resizing live.dial seems to act a bit weird too in relation between parameter name and the dial. Live.slider also disappears (I was just now changing the unit style and woof..gone from the iPad!) Seems to me that there are some fixes needed...
    • Nov 17 2013 | 7:42 pm
      Update working much better - thanks!
    • Nov 18 2013 | 7:42 am
      No icon on ipad 2 running ios5.
    • Nov 23 2013 | 7:14 pm
      Yay, it's finally working. Now I just need support for b-patchers in view, live.menu and live.arrow and I'd be so very happy. Will have to continue using lemur until then.
    • Nov 25 2013 | 11:12 pm
    • Dec 02 2013 | 3:25 pm
      Are you planning some kind of discount for Christmas?
    • Jan 25 2014 | 11:02 am
      Mira complaines when it starts up. It is looking for Mira 1.1.6 but only finds Mira 1.0.7 I've re-installed the new Mira package several times, but the app can't find the right version. I first open Max and the patch with the mira.frame. When I then open the app, the app tells me the complaint and crashes. When I then open the app the second time, it complaints but works.
      I can only find the one Mira folder on my laptop, thinking it was installed on to different locations.
      Any thoughts
    • Jan 25 2014 | 6:34 pm
      @hzd You've got the package installed at two different places somehow. Do you have Max for Live, by chance? I remember a little while back someone had the same problem as you, and it had something to do with Live copying Max externals around, or something.
      Anyway, I'd recommend that you search your computer for all files named mira.frame.mxo. There may only be one folder named Mira, but there's definitely an old version of the mira.frame.mxo file around somewhere. Find it and get rid of it.
      Let me know if that doesn't help.
    • Jan 27 2014 | 2:27 pm
      I figured it out.
      I had a project, where I had copied the patchers into the project folder. (create project local version) I gather.
      Now the app won't complain, but it still crashes the first time I open it, after that, it works. No biggie for me.
      Thx, for the lessons, the app and the help.
    • Jan 29 2014 | 3:35 pm
      Dear Sam Tarakajian, I still have problems connecting. I am using MAC OSX 10.6.8 (I have tobe able to reach my old AKAIs with the Akai software, that is not supported by higher OSX). I installed MAX 6.1.6, the new MIRA package and the new MIRA App. Still my iPad realizes my WiFi network but does not connect to my patch. It works, when I create an Adhoc-network, between my Mac and the iPad.Any suggestions, what I should do?
      Thanks for your support
      Hans Peter Kuhn
    • Feb 12 2014 | 3:19 pm
      sam, this update finally solved the networking issues on my computer. happy to be using mira now...
    • Mar 04 2014 | 2:53 pm
      Been playing with this update for a bit, report is: - Fixed my network problems, allows me to connect with my Lanbox still plugged into second ethernet port - Lost my Mira icon on the iPad, just a white square now (I'm on an iPad 1) - Occasional, but pretty regular crashes when changing tabs ( I am using full screen fpics @ 1024x768 if that is pertinent) - Occasional bizzarre re-arranging of components on iPad screen, quit patch and reopen solves - Sometimes a tab won't go away when a Max patch is closed. If I reopen the patch, Mira then has a duplicate of the tab which does't communicate. To make it go I have to quit Max entirely.
    • Mar 10 2014 | 6:42 am
      Hi everyone,
      I runs max6.1.6 with mira1.1.6 in multiple PCs in a same network, and have a connection problem.
      When I disconnect one of PCs/Macs from Mira in my iPad, soon (like, 10 seconds) the PC reconnected automatically. I confirmed this issue with various combinations of iPads/PCs/Macs. The tentative solution is to downgrade mira to 1.1.3. Although the version mismatch alarm is always popping up when I start Mira, auto reconnection does not occur.
      My question is, is there anybody who suffers from same problem??
    • Mar 20 2014 | 5:01 pm
      let's get one thing straight, i'm first to moan about moaners normally - however, i'm logging in here to see what's new (wishful thinking), all too ready to bemoan the fact that MIRA seems very very stagnant in terms of object support and finesse of the current ones - at the very least to counter the frustrations i'd like to see a roadmap of broad intentions so that there can at least be some hope of the app thriving - it's doubly sad to log in and see that the last post in this thread (at time of writing) is unchecked spam from a week ago .... is anybody here?, Sam, can you enlighten us as to the vision y'all have for MIRA {/moan} i'm ready to get stuck in but many of the things i've flagged to date are the same (since day one)