mira.frame crashing Max

    Oct 21 2013 | 4:28 pm
    I've purchased MIRA today and installed the new recently released package and found that the only way I can connect my iPad to Max on my system is by using an Ad-Hoc network with no other internet connection running. If at any point I connect to the internet again, any patches with a [mira.frame] object makes Max crash. If I make a new empty patch, the moment I create the [mira.frame] object, Max crashes too.
    My internet configuration goes Modem (DHCP enabled) -> Airport Extreme (Bridge Mode) -> Mac
    This happens regardless of the network device I'm using to connect to the internet: Ethernet or WiFi (haven't tried others like Firewire or Thunderbolt). I'm testing this on Max 6.1.4 with the latest MIRA package on OS X 10.8.5 on a Mac mini (late 2009).
    Is anybody else experiencing this issue? Any help would be greatly appreciated!

    • Oct 21 2013 | 5:33 pm
      Hey Juan, I'm really sorry to hear you're having trouble. I think the Mac mini may be the issue. Do you know how to get the crash report from Max? You just need to open Console, disclose ~/Library/Logs, disclose DiagnosticReports, right click on the crash report from Max and click Reveal in Finder. If you can post the crash report then I can maybe get a better sense of what's going on.
    • Oct 21 2013 | 6:29 pm
      Hi Sam, thanks for your reply, I'm attaching the crash reports. I made a test with my old MacBook 2006 and unfortunately had the same results: although the connection was established this time it lasted only for a few seconds, so apparently this might apply also to MacBooks (also attached that crash report). Let me know if you need me to try or test something.
    • Oct 21 2013 | 6:30 pm
      Juan, apparently the website won't let you upload crash reports. Could you please send them to support@cycling74.com with instructions to forward them to me? I'll get to the bottom of this...
    • Oct 21 2013 | 6:33 pm
      Just wrapped them in a zip.
    • Oct 21 2013 | 6:33 pm
      Just wrapped them up in a zip.
    • Oct 22 2013 | 12:31 pm
      same problem. 10.8.4, max 6.1.4 and latest mira on an iMac.
      crashes as soon as mira.frame is created.
      sending crash log
    • Oct 22 2013 | 3:51 pm
      @juan I don't see any logs posted. Did something go wrong? @drkoss Did you post the log here or send it to support?
    • Oct 22 2013 | 4:28 pm
      Didn't even know there was a new package :(( Could Mira users be warned when this happens ? This isn't stated clearly anywhere, except when reading some threads on the forum.
    • Oct 22 2013 | 4:32 pm
      @stephane There's supposed to be a warning that pops up. I guess it's not working! Sorry about that, I'll get right on it.
    • Oct 22 2013 | 5:01 pm
      Okay, I've got the reports now. Strange looking. Just to satisfy your curiosity, these are all the same crash. I'm not sure what's going on but I'll let you know when I have more information.
    • Oct 22 2013 | 6:20 pm
      I seem to be having the same problem as well. As soon as I create mira.frame MAX exits. I have tried with an adhoc network and without and I get the same response. I've attached some crash reports in case that helps.
      Mac OS 10.8.5
    • Oct 23 2013 | 4:01 am
      One question... Is everyone using the latest version of the mira.frame object? You actually need to download this again (version 1.1.4) to use with version 1.1.4 of the Mira app. Big apologies if this wasn't clear, I'm working on making it more so.
    • Oct 23 2013 | 4:56 am
      I have buy today mira and... same problem with Mira, crash when try to create mira.frame. OSX 10.8.5
      last version of max and mira
      Thank's to inform about corrections.
      My best J
    • Oct 23 2013 | 7:25 am
      I downloaded the Mira package yesterday, twice to be sure. That should be 1.1.4, right? Or was it posted afterwards?
    • Oct 23 2013 | 7:32 am
      @Juan Nope, you got it, 1.1.4. Still not sure what the problem is exactly...
    • Oct 24 2013 | 1:51 pm
      yup - i have the latest mira package here!
    • Oct 24 2013 | 2:31 pm
      @Sam - could you post a link to the old version until you figure this out? i am sort of dead in the water here and can't use the rig.
      ACTUALLY - scratch that - i imagine i'd need to downgrade the ipad app as well which probably isn't doable... Hope a fix is found soon. thanks.
    • Oct 24 2013 | 2:32 pm
      I have the same problem here after updating the mira package.
    • Oct 25 2013 | 7:06 am
    • Oct 25 2013 | 7:07 am
      Same problem here.
    • Oct 25 2013 | 9:49 am
      Doesn't crash for me. Mountain Lion (all updated…)
    • Oct 25 2013 | 11:23 am
      I tried it with another user on the same mac: does not crash!
    • Oct 25 2013 | 7:39 pm
      If you are having connection or crashing problems and you would be willing to help us solve them I can get people access to beta versions. Please email support and we'll get you going.
    • Oct 25 2013 | 8:51 pm
      @Andrew - thanks! I would love to help - put me on the beta list!
    • Oct 26 2013 | 5:23 am
      @drkoss Thanks for the help! Email support@cycling74.com, if you would, and we'll get you started. We'll need some things: email, device UDID, full psychological profile...
    • Oct 26 2013 | 9:56 am
      @starakaj, would be any option to downgrade MIRA at iPad? its been really a big inconvenience for my audio processes the delayed communication between iPad and Mac. the fluidity has been scrapped.. thanks C
    • Oct 27 2013 | 3:41 pm
      here's someone else to help for beta testing (just in case) regards, C
    • Nov 11 2013 | 1:05 am
      Hi There,
      Just wondering if anyone has encountered any fixes for this? I'm using OSX 10.9 with Max 6.1.5 with the latest Mira package and app versions. I tried launching Max in both 32 and 64 bit modes to see if it crashed in one but not the other - it crashed in both as soon as the mira.frame object was created. I've attached my crash report. Thanks!
    • Nov 11 2013 | 7:31 am
      @pmt Sorry you had to run into this bug. We've got a fix out that should be available in the next couple of days. Thanks for your patience and for the crash report.
    • Nov 11 2013 | 9:10 pm
      To anyone still having this problem, see if version 1.1.6 doesn't address your issue. Let me know right away if you're still encountering trouble.
    • Feb 01 2014 | 2:50 am
      Hello Sam, I'm sorry but I've a crash just creating the mira.frame object. I've discovered that switching of wifi, it's ok. It crashes when it tries to connect to the Ipad into the wifi. I'm on 10.9, Max just downloaded last version and last Mira 1.1.6 on a Macbook Pro 15'(2009). If you need more things just let me know.
      All the best, Pere Vicalet
    • Feb 10 2014 | 12:16 pm
      Alas this is happening here also.
      Im running Live 9.1.1 with the latest M4L and have downloaded the extra mira content. I do not have full max 6 installed on this machine, do I need to have the full install to get the M4l working?