missing base SDK

    Jul 01 2011 | 10:04 am
    I just bought a new MacBook Pro and downloaded Xcode 4.0.2 and MaxSDK-5.1.7. I put the SDK folder into the Developer folder and started one of the examples. A message appears: "1 target, missing baes SDK". What can I do about it? The "Project" menu in no longer part of Xcode's menu bar, so how can I set the Active SDK?

    • Jul 01 2011 | 10:05 am
      P.S. Sorry for the misspelling, the correct message is: "1 target, missing base SDK"
    • Jul 01 2011 | 1:15 pm
      Haven't used Xcode 4 yet, but look for the project properties page or Edit project properties. Change your base SDK to 10.5 and you may have to restart.
      If I dl Xcode 4 I'll update this post but I'll be willing to bet a google search on this will turn up more than posting here.
    • Jul 01 2011 | 2:01 pm
      In XCode 4 you can access the Project menu if you click on your project's name in the Project navigator. I attach a screen shot of one of my projects to illustrate this.
      The reason why you get the missing SDK error is that they removed the support for SDK 10.4 (just as ppc support) from XCode 4. If for some reason you need any of these, here's a quite detailed description about restoring both:
      Hope this helps, Ádám
    • Jul 01 2011 | 7:43 pm
      Thanks. I managed to find Base SDK and set it to Mac OS 10.6. I opened the pluassz example and try to build it, but I received 3 error messages. I attach a screenshot. What's wrong?
    • Jul 01 2011 | 7:45 pm
      Should be using GCC 4.2 with 10.6, as far as I know.
    • Jul 01 2011 | 10:56 pm
      If you read the article I linked, there's a description of how to restore GCC 4.0 support on XCode 4. Unfortunately I don't have enough theoretical knowledge to understand every small detail, however, since the darwin version of GCC 4.2 (as far as I know) doesn't support PPC (nor does SDK 10.6), if you want to keep PPC compatibility, you should use GCC 4.0 and SDK 10.4 (or maybe SDK 10.5 -- as I told, I don't have the knowledge to judge this).
      I've set up all my projects to use GCC 4.0 and SDK 10.4 and (as my users reported) it seems that my externals work on both Intel and PPC machines. Again, I can't tell for sure whether with other compiler settings you could achieve the same result, but at least the GCC 4.0 + SDK 10.4 combo works for sure.
      Also another hint: as Max itself is a 32 bit application, feel free to remove x86_64 from 'Valid architectures'. It shouldn't harm if you have it there, however, your compiled external would contain binaries that couldn't be used by Max anyway (so you double the size of your external and also the time that it takes to compile it unnecessarily).
      Hope this helps, Ádám
    • Jul 03 2011 | 10:17 pm
      Thanks for the information. Since I don't need PPC compatibility, I am fine with OS 10.6. I set the compiler to GCC 4.2 and the base SDK to OS 10.6, and it worked. But there are more issues with Xcode 4, so I will come up with more questions. Thanks again.