missing vecLib.framework


    Mar 01 2007 | 3:18 pm
    hi all i was recently working on a patch that calls for pitch detection and thought i would check out pitch~ and analyzer~ as alternatives to fiddle~, but i see that they both call for vecLib.framework which doesn't seem to be installed on my g4 powerbook 1.67 running 10.4.8. i did a little trolling around and found that some combo updaters delete this file, and i wonder if there is a way to install it without doing an os reinstall. any ideas? thanks for the tips bruce
    bruce tovsky www.skeletonhome.com
    "Flying is learning how to throw yourself at the ground and miss." Douglas Adams

    • Mar 01 2007 | 7:26 pm
      > i was recently working on a patch that calls for pitch detection and > thought i would check out pitch~ and analyzer~ as alternatives to > fiddle~, but i see that they both call for vecLib.framework which > doesn't seem to be installed on my g4 powerbook 1.67 running 10.4.8. > i did a little trolling around and found that some combo updaters > delete this file, and i wonder if there is a way to install it > without doing an os reinstall. any ideas?
      I've been helping Bruce off the list, and though it would be of general interest to post these links:
      Since I already have these frameworks, I have not been able to this advice. If somebody does solve this problem, it would be of great service to the community if they would post their solution here.
      Thanks,
      mz
    • Mar 01 2007 | 8:08 pm
      i guess we can continue this here....
      michael (and anyone) a couple of questions: first, i should point out that the first link below is bad (leave off the "and" between the lines.) this link points to the files where i got the info about it being a known problem and that running the updater generally fixes it. the second link points to the os x SERVER 10.4.8 combo updater and what i think is needed is the osx 10.4.8 combo updater, please correct me if i'm wrong. however, if vecLib.framework is only installed by the server updater then let us know. i'm downloading the 10.4.8 combo updater now, but isn't the combo updater what caused all that java mischief several months ago? or was that an earlier 10.4 combo updater? cheers b
      On Mar 1, 2007, at 2:26 PM, mzed wrote:
      > >> i was recently working on a patch that calls for pitch detection and >> thought i would check out pitch~ and analyzer~ as alternatives to >> fiddle~, but i see that they both call for vecLib.framework which >> doesn't seem to be installed on my g4 powerbook 1.67 running 10.4.8. >> i did a little trolling around and found that some combo updaters >> delete this file, and i wonder if there is a way to install it >> without doing an os reinstall. any ideas? > > I've been helping Bruce off the list, and though it would be of > general interest to post these links: > > http://lists.apple.com/archives/PerfOptimization-dev/2006/Apr/ > msg00005.html > and > http://www.apple.com/support/downloads/ > macosxserver1048comboupdateppc.html > > > On the subject. Since I already have these libraries, I have not > tested this advice. If somebody does solve this problem, it would > be of great service to the community if they would post their > solution here. > > Thanks, > > mz > > > -- > || michael f. zbyszynski -- molecular gastronimist > || http://www.cnmat.berkeley.edu/ > || http://www.mikezed.com/ > > >
      bruce tovsky www.skeletonhome.com
      "The secret to creativity is knowing how to hide your sources." Albert Einstein
    • Mar 01 2007 | 11:27 pm
      > i'm downloading the 10.4.8 combo updater now, but isn't the combo > updater what caused all that java mischief several months ago? or was > that an earlier 10.4 combo updater?
      There was a problem exactly like yours with the 10.4.6 update that was *solved* by the combo update. This is one thread:
      The PPC 10.4.8 combo update is here:
      or
      But I still don't know if it will 1) Install the Frameworks you need, and 2) Fix the problem with analyser~, et al.
      mz
    • Mar 02 2007 | 12:53 am
      That lib should never get blown away... are you sure that /System/ Library/Frameworks/vecLib.framework is missing?
      _Mark
      On Mar 1, 2007, at 7:18 AM, bruce tovsky wrote:
      > hi all > i was recently working on a patch that calls for pitch detection and > thought i would check out pitch~ and analyzer~ as alternatives to > fiddle~, but i see that they both call for vecLib.framework which > doesn't seem to be installed on my g4 powerbook 1.67 running 10.4.8. > i did a little trolling around and found that some combo updaters > delete this file, and i wonder if there is a way to install it > without doing an os reinstall. any ideas? > thanks for the tips > bruce > > bruce tovsky > www.skeletonhome.com > > "Flying is learning how to throw yourself at the ground and miss." > Douglas Adams >
    • Mar 02 2007 | 5:13 pm
      Quote: Mark Pauley wrote on Fri, 02 March 2007 01:53 ---------------------------------------------------- /System/Library/Frameworks/vecLib.framework
      vecLib.framework is located in the Accelerate.framework:
      "file:///System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/"
      PG
    • Mar 02 2007 | 8:56 pm
      mark you are correct, it is there. stupid me did not think that it would be invisible to "find" and the file path i searched manually before was /Library/Frameworks not /System/Library/Frameworks - i was led astray by a post i read on the developers forum. thanks for the tip. now to get back to figuring out why i'm not getting analyzer~ to work... cheers bruce
      On Mar 1, 2007, at 7:53 PM, Mark Pauley wrote:
      > That lib should never get blown away... are you sure that /System/ > Library/Frameworks/vecLib.framework is missing? > > _Mark > > On Mar 1, 2007, at 7:18 AM, bruce tovsky wrote: > >> hi all >> i was recently working on a patch that calls for pitch detection >> and thought i would check out pitch~ and analyzer~ as alternatives >> to fiddle~, but i see that they both call for vecLib.framework >> which doesn't seem to be installed on my g4 powerbook 1.67 running >> 10.4.8. i did a little trolling around and found that some combo >> updaters delete this file, and i wonder if there is a way to >> install it without doing an os reinstall. any ideas? >> thanks for the tips >> bruce >> >> bruce tovsky >> www.skeletonhome.com >> >> "Flying is learning how to throw yourself at the ground and miss." >> Douglas Adams >> >
      bruce tovsky www.skeletonhome.com
      "Reality is whatever refuses to go away when I stop believing in it.." Philip K. Dick
    • Mar 08 2007 | 9:24 pm
      I may post this separately but I have not got this framework thing on my mac
      I have 10.4.8 on a G5 imac (pre intel) running maxmsp 4.5.5 and jitter 1.5.2
      I have checked in the file path suggested and there is no framework file as detailed in your post. I am trying to get analyzer~ to work but it comes up as bogus
      Have you solved this issue now?
    • Mar 08 2007 | 9:44 pm
      adrian i made two mistakes: one was doing a search using "find" - the vecLib.framework will not show up in "find" without setting it to look for hidden and/or system files. my second mistake was looking in /Library/Frameworks and not /System/Library/Frameworks - which is where i found it. however, i was also not getting throughput with analyzer~ (which is why i assumed that vec.Lib wasn't there) and i haven't revisited it yet to explore more. hope this helps b
      On Mar 8, 2007, at 4:24 PM, Adrian wrote:
      > > I may post this separately but I have not got this framework thing > on my mac > > I have 10.4.8 on a G5 imac (pre intel) running maxmsp 4.5.5 and > jitter 1.5.2 > > I have checked in the file path suggested and there is no framework > file as detailed in your post. I am trying to get analyzer~ to work > but it comes up as bogus > > Have you solved this issue now?
      bruce tovsky www.skeletonhome.com
      "To know is nothing at all; to imagine is everything." Albert Einstein