mtof~ not working in 64bit ?


    Feb 26 2014 | 9:52 am
    Hi, Is it me or the mtof~ object doesn't work in Max 64 bit ? mtof is fine, but mtof~ is apparently unable to load. Thx.

    • Feb 26 2014 | 12:50 pm
      Make sure you don't have an old version of mtof~ somewhere in your search path. You should just have the one in Cycling '74/msp-externs/mtof~.
    • Feb 26 2014 | 11:05 pm
      Thanks Emmanuel, I've already check this as I have seen another topic mentioning this. Unfortunately my problem is not solved. But mtof~ is loading perfectly fine in Max 32bit, that's why I'm asking.
    • Feb 26 2014 | 11:50 pm
      Ok. It's resolved. What I can tell about the problem I was having is that it was related to Granulator II (m4l). That's, btw, by trying to play this synth in Live 64 bit that I noticed the problem. Granulator is frozen with an old version of mtof~, and at some point I had to unfroze it. And it seems that since that day, Max was referring to the mtof~ situated in the Granulator "unfrozen devices..." folder, and not to the default one in the regulate map externals folder; not only for granulator but every max patch, in 64 bit. So, I had to open Granulator, choose the right mtof~ in the "resolve conflicts" window, unfreeze it, save it, freeze it and then delete the Granulator folder in the "max for live devices" folder (or the "unfrozen devices" max for live folder, as I called it before). I has to do it twice actually, because the first time, when I re-opened the device, the resolve conflict window offer me to choose between the new one (the good one actually, in the map externals folder) and the "older"one whose date was something like May 2040 !? Ok, sorry for this long and badly told explanation, I just tried to give details in case this could be a bug. Julien