Multislider bug or feature?

    Sep 01 2013 | 1:49 am
    I'm going over one of the Max4Live tutorials discussing the velocity, MIDI, sequencer. I found out that other people were having the exact same problem I had.
    The problem is that the multislider would not save the amount of sliders you input in the inspector. For example I set the sliders to 16. When you save the patch it automatically goes to 1.
    I found out the fix is that you set up a message box of [size 16] going to the input of the multislider. After you save the patch, you click the message box and that fixes the issue.
    My question: bug or feature? I assumed that if I set the number of sliders to 16, that it should automatically save that amount. Am I wrong in that understanding? Does this apply to other objects?

    • Sep 01 2013 | 12:33 pm
      Hm. There is something wrong.I just tried saving a plain patcher with just a multislider set to 15 sliders. closed it opened it and I don't have the problem, it came up with the 15 sliders. Maybe m4l specific? Workaround suggestion: freeze the attribute? Loadbang your messagebox? Parametermode enable?
    • Sep 01 2013 | 8:22 pm
      Perhaps you're inadvertedly sending it a single float or int somehow? Perhaps through the pattr object?
    • Sep 26 2013 | 6:46 am
      Behold, I believe I have found the answer! It is indeed the (pattr steps) object causing this problem (this became evident when the prescribed size 16 message box solution did not in fact work). To fix this issue, click on the pattr steps object and open the inspector. Under the Parameter heading, find the Type field, and change from Int (0-255) to Blob, then re-save the patch. The multislider should now stay at 16 bars, and Live will save the sequencer settings when you reload the project.