.mxo files becoming folders

    Nov 17 2010 | 6:57 pm
    naturally, this post relates to OSX.
    i have lately had a few of my third-party externals' .mxo files mysteriously become folders, and no longer visible as externals by max. anyone else had this issue? there are too many to name them all individually here.
    Mac Intel OSX 10.5.8, MMJ 5.1.5
    i completely reinstalled my OS a few weeks ago, and Max of course. i think it has been happening since then only. any ideas before i attempt prefs trash and reinstall of max? (i do hate to do that).

    • Nov 17 2010 | 10:18 pm
      i've seen this once and i've forgotten what to do.... but it is probably because of the MacOSX reinstall. (nothing to do with install of Max itself; the OS is seeing the packages as folders which is how older MacOSX would see it)... i thought i fixed it by doing something having to do with XCode, but I can't remember... you might want to email support @ cycling then let us know what they say...
      ________________________________ *Never fear, Noob4Life was never here!*
    • Nov 21 2010 | 11:54 am
      ok, i had begun a very useful emil exchange with support about this, but, awaiting for another reply, i actually did a bit more digging and 'solved' the problem.
      after the amazing new syphon was released, i followed some links and thought it would be interesting to have "untiy" app on my system. this is ironic because i am on 10.5.8 and syphon requires 10.6 anyway, but i keep meaning to update.
      looking in my c74 externals folder, i noticed that all my native max externals had a plain white icon instead of the usual max external icon. getting info on one of these i noticed that the unity utility app "unitron" had taken over all max externals since its install. it had made max externals turn white icon, but not affected the usage of these inside max itself. however it had turned all third party externals into blue mac os folders and prevented them from loading in max. as if it had 'uncompiled' them somehow. weird. i simply reset the 'open with' command, chose 'change all', dealt with a computer crash, restarted, did it again and now EVERYTHING is back to normal. the third party externals, which had become openable folders, are no longer folders but proper externals again.
      any further thoughts from anyone would be great. but at least this is maybe interesting in case it happens to any other such tools as me.
      sorry for all the noise in general.
    • Nov 03 2014 | 3:05 pm
      there is a wonderful fix here: http://abstrakt.vade.info/?p=62 MAKE SURE TO READ THE COMMENTS ABOUT THE iLaXmax2 MODIFICATION. this person also made a patch that supposedly does this automatically, but I couldn't get it to work. So I made an instance of Pkginfo and copy/pasted as needed
      it still works on 3 Nov 2014, Max 6.1.7, OSX 10.9.5. cheers!
    • Mar 19 2018 | 10:38 am
      I have this problem with the Myo For Max Package. I tried DSIWIAK´s advice and was able to change the myo.mxo folder into a bundle with a white icon using the iLaXmax2 modification. Still I am not able to use the code from the package in Max. The objects are displayed as brown.
      Does anyone know about a solution for this?
    • Oct 14 2018 | 2:55 pm
      I had the same problem after doing a clean install of my system. My fix was simpler: - select a .mxo "folder" in the finder - Get info - Select Max in the "Open with:" menu - Click the "Change All..." button below.
      That worked for me, I hope it will for others, too