New Apple M1 chips - MacBook Pro /Air /Mac mini


    Nov 19 2020 | 12:10 pm
    Hello All,
    Does anyone knows if Max runs fine with the new M1 processors? I've seen a couple of people running Ableton but no one running Max for Live or Max I was wandering what are the thoughts about this new chips around here?
    This guy seems to have good results on an Ableton test in M1: https://www.youtube.com/watch?v=MDlWZwvUZPI
    I would LOVE to see a jitter benchmark on Max on a M1 chip:
    https://cycling74.com/forums/v2-benchmarking-jitters-cpugpu-performance-on-your-computer-v2/replies/1

    • Nov 20 2020 | 2:07 pm
      ...Or maybe has someone tried Max with Big Sur?
    • Nov 20 2020 | 3:38 pm
      Max 8.1.8 supports Big Sur with Intel machines. Apple Silicon is not officially supported yet. Under Rosetta, there are some currently known issues, which will be fixed in an updated version sometime in the next few months. We are working on a native Apple Silicon version of Max, but we do not have a timeline for when that will be released.
    • Nov 24 2020 | 2:43 pm
      Can you confirm that a native Apple Silicon update is coming to Max 8? Thinking about buying but would first like to make sure in case I upgrade to an Apple Silicon Mac in the coming year or two.
    • Nov 24 2020 | 5:17 pm
      I'm actually curious what the improvement is with MSP. All anyone online can talk about is final cut pro.
    • Dec 03 2020 | 12:09 pm
      @Audiomatt
      Yep, I'm also thinking about the same topic. There is something called "High-efficiency audio processor" inside the M1 chip. But I couldn't find any information if this subsystem is exposed for developers and can be used to accelerate audio computations. If not, MSP will be, IMHO, more or less untouched by the transition to new chips (maybe a bit more robust if the new chip is really as fast as Apple says).
      However I can imagine, that other parts of the M1 (accelerators for machine learning and "neuromorphic" calculations) can open some new possibilities for audio processing. Also the sneaky memory management (UMA) can be useful for better integration between MSP and non-MSP domains.
    • Dec 03 2020 | 2:52 pm
      I got my new M1 mac mini yesterday and installed max straight away. After jumping through a few Big Sur security hoops, I ran my three main big patchers, 2 of which are mainly time stretchers (one for "studio" work and the other for live performance, with lots of usb midi controllers). So far, absolutely no problems running the patchers. And I have the vector sizes set much lower (in fact, at the default settings) which I haven't been able to do for quite a long time on Intel Macs. Everything seems to be running smoothly and responsively. I don't do any video work, so I can't say if there are any problems there, but audio is looking good. I have a school workshop to run next week (as long as no-one at the school comes down with Covid!), so I'm going to try running that system on the M1 Mini. That involves sensors coming in via a Phidget 8/8/8 (I've already checked that that works), and USB midi, and DMX out over ethernet (the Enttec ODE seems to be working, but I haven't hung any lamps off it yet). That will give the processor a more serious workout. And I'll see if the computer remains as delightfully cool as it is at the moment!
      I'd be interested to know ( @RobRamirez ) what the known issues with Max are, in case it affects anything I'm doing.
      Edit: On running one of the patchers, I'm getting the following message in the Max Console. Anyone any idea what this is? ... xebra_global . XEBListeningConnection_ListenProc: Error accepting connection: 670008 nodename nor servname provided, or not known
    • Dec 03 2020 | 3:27 pm
      @david lower vector sizes are fantastic news. If I can get my VS down less than an mmillisecond I can stop obsessing over the friction of scheduler and audio rate ruining the groove.
      that might have been the push I needed.
      also, when you say you have a time stretched for studio work, are you saying it’s higher quality in nonreal time? I’d love a replacement for sera to pitch n time but it’s just the best sounding algorithm on the market.
    • Dec 03 2020 | 3:29 pm
      I believe xebra is part of mira.
    • Dec 03 2020 | 3:33 pm
      Ah. So that's probably because I don't have Mira active on my ipad.
    • Dec 03 2020 | 3:34 pm
      Speaking of Mira, I’m not one of these people but people have been begging for max on iPad for what seems like millennia. I wonder if this takes us a step closer.
    • Dec 03 2020 | 3:39 pm
      @audiomatt. Not quite :-). One of the patches has a bunch of time stretchers (6 granny and 5 mubu) and is for creating a lot of raw material fairly quickly (hence "studio") in real time, whereas the other patch does time stretching and granulation mostly played using a BopPad and Launchpad (and Mira) for live performance. I'm very happy with the sound of both granny and mubu for long stretching; and the artifacts are nice too.
    • Jan 04 2021 | 10:59 am
      hello everyone, I tried to install the enttecc DMXUSB PRO on mac mini with m1 processor (+ Rosetta). On Max I installed Olaf Matthes's dmxusbpro.mxo, which installs correctly, but the hardware device is not recognized. Any suggestions? thank you all.
    • Jan 04 2021 | 11:31 am
      I don’t know if this will be the same, as I’m using the enttec ODE rather than the USB version. First thing I do is to use my web browser to check that the enttec is being seen by the computer. Enter the url for the enttec (printed on a label on the packaging box) into your browser address field. If it doesn’t work like that for the usb interface, have you checked the connection using enttec‘s control panel? (Though I think that that may not be working with Big Sur). I found Enttec’s support to be very helpful when I was having similar issues a few months back. Also maybe re-install the dmx objects? I use the imp. objects and they are working fine on an M1 Mac and an ODE. HTH.
    • Jan 04 2021 | 11:53 am
      @MICHELEFIORI does it show up with the [serial] object? Some of students had trouble with the DMXUSBPRO external already under MacOs Catalina (with Intel processors). The solution was to use the vanilla [serial] object and create an abstraction that parses the data before sending.
    • Jan 04 2021 | 10:02 pm
      Thanks for the help, in fact I found the solution with direct connection on the serial port, here is the patch!
    • Feb 17 2021 | 8:32 pm
      Hey guys! any news on max with M1 without Rosetta?
    • Mar 03 2021 | 3:59 pm
      +1. Would really appreciate an M1 build, especially as people report that the high SSD writes are due to Rosetta 2.
    • Mar 04 2021 | 6:30 pm
      Hello! Im soon gonna purchase a M1 mac for max enteirly. Is this recommended? How is it working for people here? Cheers