New to Max MSP - no sound.

    Jan 02 2012 | 1:52 pm
    Hi everyone. I'm building a sampler for a project, and I can't get any sound from Max MSP. Everything is patched fine, audio is on in the DSP settings (I've tried making the output my macbook pro built-in output and my mbox2 Mini with no luck for either), the ezdac is on, but no sound. I've tried an oscillator in audiotester and got nothing, I'm not sure if you're supposed to see a wave in the audiotester when the oscillator is on, but I didn't. I sent the patch and samples to a friend and it works fine for him, so I have absolutely no idea why I can't get any sound. I'm running the patch in Max5, and downloaded the Demo of Max6 to see if that solved the problem, but still no luck. If anyone could shed any light on the situation it would be very much appreciated.
    Specs, if needed: Macbook Pro (2009) 4Gb RAM 2.8 GHz Intel Core 2 Duo 500GB Hard Drive Mac OSX 10.7.2
    Thanks in advance, Mike.

    • Jan 02 2012 | 2:02 pm
      have you tried to follow any of the simple the built-in MSP tutorials and see if these work?
    • Jan 02 2012 | 2:14 pm
      Just tried a tutorial and got sound... I'm confused. I have no idea why my patch, with no alterations at all, works for a friend, but not for me.
    • Jan 02 2012 | 2:28 pm
      just try step by step, reduce it to its bare minimum (remove patch cords) and see what can cause the problem. start from scratch, copy parts of it, slowly build up...
    • Jan 02 2012 | 6:56 pm
      post your patch
    • Jan 02 2012 | 7:55 pm
      Here's the patch: I've done it as a zip to include the samples as well.
    • Jan 02 2012 | 9:47 pm
      While looking into this, I ended up significantly refactoring your patch.
      First, save this as Sounder.maxpat:
      Next, here's your top level patch, edited to use the Sounder abstraction:
    • Jan 02 2012 | 9:49 pm
      i just tested it. I only got sound by pressing the C1 note. All the others don't produce any probably due to a typo: if you double click the p Sound2 object while the patch is locked, you will see the patch within. there the filenames of the sampler wav files are mentioned - however they miss the file extension .wav as in the p Sound1 patch.
      so it maybe a typo in all those except C1 that is causing you the headache. try it and let us know...
    • Jan 03 2012 | 12:58 pm
      zigzag - Yeah, you were right, it was a typo in the sub-patches. It's playing now, but the quality of the playback is pretty sketchy, so I think I need to do some work on the buffer lengths. Thanks for your help.
      Chris Muir- Thanks, this patch is working perfectly.