no driver midi_adrewire error

    MaxMSP

    earth2j's icon
    earth2j's icon
    earth2j
    Mar 24 2019 | 11:12 am
    Been using Rewire with no issues but decided to use it this morning and I'm getting this error:
    no driver midi_adrewire
    I went into m y Audio settings and it shows Midi Ports 0. But when trying to change it to 1 it refuses it.
    Any ideas on what I can do to fix this? A quick search turned up nothing.

    • Shane Turner's icon
      Shane Turner's icon
      Shane Turner
      Mar 29 2019 | 6:14 am
      I too am getting this. Rewire is broken for Max 8 on my Win 10 machine. Even though Max 8 shows up in the ReWire registry keys (HKLM\Software\Propellerhead...\ReWire), when I select any ReWire host, reaper, bidule, etc, only the previous version, 7 is showing up. I uninstalled Max 7 and 8, cleared the ReWire registry keys, reinstalled only 8 today with the latest install, and ran Max for the first time as an admin to install the ReWire device. It oddly, from within the Max 8 console, said that it was installing ReWire for Max 7! Whatever the cause, I'm sadly still stuck with this error.
      Share
    • earth2j's icon
      earth2j's icon
      earth2j
      Apr 11 2019 | 8:14 am
      Ok, then I'm not alone in having issues with Rewire in Max 8. I'd rather stay away from the registry if I can but I might try out the same thing.
      Are you able to use Rewire still?
    • Shane Turner's icon
      Shane Turner's icon
      Shane Turner
      Apr 11 2019 | 9:35 pm
      Sadly no dice. I reinstalled and I still have the same error message. Looking at the registry won't fix anything, so I wouldn't suggest bothering if you aren't familiar with it anyway (My day job is a sysadmin)
      I also have a 2012 MBP running a clean install of Mojave for music on the go. I installed Max 8.04 and I still had the same problem with ReWire. "no driver midi_adrewire" shows up in the console. So I wonder if this is a common problem with Max 8?
      I'm going to try the 8.05 installer later today, and if that still doesn't work, contact support. Or I'll have to go back to version 7. Right now I can't use Max in any of my ReWire applications :(
    • earth2j's icon
      earth2j's icon
      earth2j
      Apr 11 2019 | 9:44 pm
      I'm on 8.05 with the same error but hopefully it'll work for you...let us know if it does. I can send audio to Ableton Live (I haven't tried my other DAW's yet) and record the audio but other than that I have no idea what might go wrong. Sort of new to this so will just wait it out and see if it gets fixed soon. It's a weird issue for sure.
    • Shane Turner's icon
      Shane Turner's icon
      Shane Turner
      Apr 12 2019 | 9:50 am
      I tried it--no luck with 8.05 for me either. Still the same error.
    • Ronald Legere's icon
      Ronald Legere's icon
      Ronald Legere
      Apr 18 2019 | 6:26 pm
      Getting same error here, on Max 8.05 on windows. (And yes I can send audio out , but no midi in. GRRR)
    • Shane Turner's icon
      Shane Turner's icon
      Shane Turner
      Apr 18 2019 | 7:16 pm
      I submitted a support request for this, let's see if its a config issue or bug that needs to be patched...
    • Ronald Legere's icon
      Ronald Legere's icon
      Ronald Legere
      Apr 18 2019 | 8:47 pm
      I submitted as well.
    • Ronald Legere's icon
      Ronald Legere's icon
      Ronald Legere
      Apr 19 2019 | 4:08 pm
      Support got back to me , and they said it appears to be a bug introduced in 8.0.4 (they will add it to the list) and in the meantime you can roll back to 8.0.3 if you need this capability. They provided a link (and gave me permission to share it here) for 8.0.3: https://akiaj5esl75o5wbdcv2a-maxmspjitter.s3.amazonaws.com/Max803_190108.dmg
    • earth2j's icon
      earth2j's icon
      earth2j
      Apr 19 2019 | 4:27 pm
      Thanks for the info Ronald...makes sense, around the time I upgraded to 8.04 I started having issues.
    • earth2j's icon
      earth2j's icon
      earth2j
      Jun 12 2019 | 10:27 am
      Looks like it's been fixed in 8.0.6! :)
    • Ronald Legere's icon
      Ronald Legere's icon
      Ronald Legere
      Jun 13 2019 | 1:02 am
      Confirmed, working again!