No success creating standalone in Windows XP

    Feb 22 2007 | 10:09 pm
    I'm trying to create a standalone program in Windows. I'm a Mac man forced into Windows for this occasion, there might be some Windows strangeness that I'm not aware of. Anyway, I can't create even the simplest program in Windows.
    I use the about the same procedure as I do in OSX. The program seems to be created, but when I open the .exe-file, there's only an empty, grey runtime space. No messages in the Max window. Trying the menu command "midi setup..." produces only a new, completely white window, and three messages in the Max window complaining that it can't find MidiSetup Input, Output, and Buttons.
    When I compare the content of the application folder with what the manual says should be there, nothing is missing. There's one more file than expected, the msvcr71.dll (in addition to the msvcr70 described in the manual).
    Clicking the .mxf-file in the folder opens the patcher in MaxMSP. Building a collective works fine, but no luck with the standalone.

    • Feb 24 2007 | 3:33 am
      Most common mistake is forgetting the sacrifice of one small child with each compliation of the standalone. Without the child's soul, how could you expect the standalone to function correctly?
    • Feb 24 2007 | 2:50 pm
      Thanks for the tip. I will try that if nothing else works. I'd like to try other options first though, because where I live, you can in fact get in jail for such actions if you're unfortunate.
      So other suggestions are still welcome.
    • Feb 24 2007 | 3:34 pm
      maybe you can give us the example patch to test it on others PCs ?
    • Feb 25 2007 | 12:58 am
      I could post a patch, but it could be any patch. I tried at first a quite complex one, with lots of things included in a folder. Then I built a patch with only a few random objects in it, and nothing else included. Same result.
    • Feb 25 2007 | 1:10 am
      post the patch.
    • Feb 25 2007 | 1:30 am
    • Feb 25 2007 | 6:28 am
      yeah, it works fine on mine too. But, it's not without a bit of trickery that must be mastered. I am curious as to what's the case here.
    • Feb 25 2007 | 10:06 pm
      Being a PC man myself i have come accross a couple of compiling/export problems before.
      - sometimes i need to write .dll or .exe after the file name else it don't even try to compile it. Mainly on pluggo VST exports but sometimes on stand alones. - sometimes when i use java UI's or java scripts it just won't work full stop. - sometimes when i use loads and loads of send and recieves it corrupts.
      These are only from personal experience so may not apply to your situation...but it may help.
    • Feb 25 2007 | 10:35 pm
      Well, I just can't help without a patch. I have to be able to look at the patch and the script and what externs you're using and all that.
    • Feb 26 2007 | 1:14 am
      I've compiled many standalones on PC and never had a problem. Sounds like something is corrupt somewhere. You might try a reinstall of the software.
      Before you do that, make sure when you are compiling it that you specify a file name without a ".". So the only "." in the file name after it is compiled will be the .exe. I vaguely remember having a problem similar to this about a year ago. It may not be your problem though.
      Good luck.
    • Feb 26 2007 | 2:11 am
      yes, in folder option you need to turn on "show file extensions". this the same as with pluggo. This part is absolutely essential to the complilation process.
    • Feb 28 2007 | 2:29 pm
      Which folder do you mean? All folders I|ve come across show file extensions, including my program|s folder and the folder containing MaxMSP.
      Anyway, here|s a really nice patch for you. It|s got a button you can press, and it will turn yellow as you do so.
      Max Patcher
      In Max, select New From Clipboard.
      The program (attached)compiled from this patch is a lot more minimalistic. It|s just a nice, grey background.
      (also: can anyone explain to me why I|m using the "|" in "I|m"? I thought I found the right key combination on the PC, but it turned out to be "
    • Feb 28 2007 | 3:17 pm
      Genius patch. And I'm sure you'll be annoyed to know that it works perfectly on my computer. Do this before you do anthing else:
      1. Open your "My documents" folder (or any other folder for that matter. 2. Click the Tools dropdown at the top, then select Folder Options... 3. Select the View tab 4. About 11 lines down is a checkbox with the text "Hide extensions for known file types". Make sure this in NOT CHECKED. 5. If it is checked (which I assume it is), after unchecking it, click the button at the top which says "Apply to All Folders"
      Now try building the standalone again. Better yet, try running your Untitled1 standalone. I'm curios if it will now work on your machine. As I said, it works fine on mine.
      Extensions work differently in Windows than they do in Mac. Windows basically decides what to do with a certain file based on that file's extension. This is why if you work on Mac in Max and you never include the .pat or .mxb extension in your patches, Windows doesn't know what to do with them. If you move across platform regularly (which I do), I recommend always including the extension, whether on Mac on Windows.
    • Feb 28 2007 | 3:19 pm
      Update: I just downloaded and reinstalled MaxMSP.
      No difference.
    • Feb 28 2007 | 3:37 pm
      The file extensions were showing everywhere, but I did what you said just to be sure. Again, no difference.
      Has anyone tested the attached application from my previous post? What does it look like?
    • Feb 28 2007 | 4:23 pm
      I tested it and it works fine - exactly as it should: one bang object in a window. That's actually what I was referring to in my previous post. I mistakenly said "patch".
      Now I have no idea what the problem is. You're running 4.6.2?
      Just to be clear, is this exactly what you are doing?
      1. File, Build Collective, Application. Plugin... 2. Press the Build button 3. Choose application from "save as" type 4. click save
      If not, give us the exact details.
    • Feb 28 2007 | 4:32 pm
      That's the exact procedure I'm using. Maybe it's something with the OS on the PC? What could it be, in that case?
    • Feb 28 2007 | 6:33 pm
      Zachary Seldess wrote: > extension. This is why if you work on Mac in Max and you never > include the .pat or .mxb extension in your patches, Windows doesn't > know what to do with them. If you move across platform regularly > (which I do), I recommend always including the extension, whether on > Mac on Windows.
      Side note: I much prefer .mxt to .pat - .pat is ambiguous (can be binary or text) and is also claimed by Adobe for pattern maps. At least on my machine, .mxt means "Max text" and nothing else.
      Now if there were only a way to force Max to default to .mxt, instead of Max forcing me to manually change it every single time I want to save a file, I'd be happy.
    • Feb 28 2007 | 10:20 pm
      I don't mean to be rude, but dlurk, you havent supplied a single bit of information to help any of us help you. This thread, for a week or whatever, has been completely pointless. why don't you pick someone you trust, send them the patch, and let them explain the scripting process to you or whatever it is you're having problems with?
    • Feb 28 2007 | 10:40 pm
      The application you supplied in the attachment runs fine on my Windows OS. Maybe there's something wrong with your Windows installation when you *run* the standalone application. Anybody here who knows what it could be, that could interfere with the running of a Max standalone application ?
    • Feb 28 2007 | 11:22 pm
      Hey jamez - I think it's _me_ you're trying not to be rude to, not poor dlurk :)
      I have to disagree - this thread has been very helpful, even your first answer had something to it. I forgot to be grateful, but here I go: thanks for all the tips and suggestions, everybody!
      It was, for example, very useful to learn that the application I posted works on other systems. Now I'm kind of curious as to why it doesn't work for me on the PC I'm using.
      I've tried to help you help me the best I can. There are detailed descriptions of my failure my previous posts. If there are other details I should supply, please name them. Remember: I'm too ignorant in the PC world to have an idea about what I don't have an idea about.
      So if anyone has the faintest interest in finding out of this, I'm still very grateful for new suggestions. If it's something with this particular PC's setup, I'll dig up details when I know what to look for. What I can say now (until next time I get to enjoy it's presence): it's some kind of Windovs XP Home edition, with a freshly installed latest version MaxMSP.
      I could (and will) carry on on a different PC, but I'm making applications for others to use, and this might happen to them too. It would be nice to have an answer to them in that case.
    • Feb 28 2007 | 11:43 pm
      - And please, don't upload my application (the one in the attachment) on torrent sites and such. I'm considering making a living on it. Piracy kills music!
    • Mar 01 2007 | 12:00 am
      The good news is that you will most likely NOT run into this problem again on a different computer. I've never seen anything like it when running my standalones on different PCs. Have said that though, I am also curious why it's happening.
      First, just to be thorough, I've linked the same patch made into a standalone on my system. Can you run it, or do you get the blank max screen for this as well?
      Next, click on My Computer. In the left of the window you should be able to click "View system information". Tell us what it says system and computer.
      My wild guess without seeing this info is that your OS is in severe need of updating (maybe it's still Service Pack 1? You tell us.)
      Next, I would go to the windows update website ( and see if there are updates available.
    • Mar 09 2007 | 7:44 pm
      Here I am again.
      I haven't done my homework yet (checking the OS details of the faulty PC). I've been working and compiling on another PC, with no problems (just a question, which will get its own thread).
      (I'm very fond of parentheses today it seems.)
      However, I discovered only by accident a way of getting the exact same behaviour on my mac (except there's a blank Max window in stead of the grey runtime window). To achieve this, just compile as usual, but change the name of the application (i.e., the folder that looks like a program) afterwards.
      I'll check with the bad PC soon to see if there's something suspicious about the naming of the folder and the .exe file. I doubt there is, because I looked quite thorough at things when I was having these problems, but I'll have another look at it.
      This new discovery may suggest it's all about naming and/or file path problems, or what do you think?
    • Mar 10 2007 | 4:11 am
      Quote: dhk wrote on Thu, 01 March 2007 12:43 ---------------------------------------------------- > I'm considering making a living on it.
      You know there's a $1000 license fee payable upfront if you want to sell an app made with Max for Windows, right?
    • Mar 10 2007 | 5:32 am
      Is that true about the fee?
      Heh, I'd be surprised if any app made with max/msp ever sold enough copies to make up for the $1000 fee. I think whoever instated that greatly overvalued the ability to create standalones.
    • Mar 10 2007 | 5:47 am (newer releases are Quartz/Cocoa, old revs of VDMX/ Grid are Max+SoftVNS)
      yeah. There are more.
      On Mar 10, 2007, at 12:32 AM, jamez wrote:
      > > Is that true about the fee? > > Heh, I'd be surprised if any app made with max/msp ever sold enough > copies to make up for the $1000 fee. I think whoever instated that > greatly overvalued the ability to create standalones.
      v a d e //
    • Mar 10 2007 | 12:09 pm
      At 9:32 PM -0800 3/9/07, jamez wrote: >Is that true about the fee? > >Heh, I'd be surprised if any app made with max/msp ever sold enough >copies to make up for the $1000 fee. I think whoever instated that >greatly overvalued the ability to create standalones.
      You greatly underestimate the value of those Max apps then!
      Dan -- Dan Nigrin Defective Records 202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X / Major Malfunction
    • Mar 10 2007 | 1:20 pm
      show me a standalone worth buying. :-P