Noob: XY to control fft EQ filter help.

    Jan 15 2013 | 4:47 pm
    Hi can anyone give me some advice on how to create a list of Y values to distribute over X values to be able to control n FFT filter EQ with an XY controller.

    • Jan 15 2013 | 6:20 pm
      Sounds like this is a school assignment, huh?
      Have a look at [pictslider], but there isn't enough space in this thread to explain fft processing in max, I think :-/
      I'd suggest going through the MSP tutorials, which do touch upon fft a bit.
    • Jan 15 2013 | 8:52 pm
      Yeap, I have attached the part of the patch I am working on, if you have any advice that would be great.
      I am using pictslider and have the fft filter eq, just need to suss the controlling of frequencies with the XY.
    • Jan 15 2013 | 9:57 pm
      aaah, so you're trying to control a multislider with an xy input. Got it.
      The biggest issue in solving this is that you need to upsample your input, because you have 512 sliders, and only 128 steps of resolution on your midi input.
      I solved this by doing extra draws with uzi. There may be more elegant solutions, but this seems to work - just don't do it with the pictslider itself, it doesn't output all its values, it would seem.
      Try this, see if it works:
    • Jan 16 2013 | 1:34 am
      here's a modification to Wetterberg's patch where the interpolation works with pictslider, too.
      Cheers, Ádám
    • Jan 16 2013 | 1:14 pm
      That's pretty cool, Ádám! I reckon that mode of interpolation is a bit too harsh for xy pad use, though - touch two places and it'll draw a direct line between them, which is a bit radical for some uses.
    • Jan 16 2013 | 1:47 pm
      Yeah, it needs some improvement. The original idea was that, since pictslider is probably using qelems to trigger it's output, when you click-and-move the mouse inside the object, you won't get a continuous output. My approach works basically to overcome this problem. Probably a timer+gate combo or something similar should be inserted to turn off the 'direct line interpolation' effect. Cheers, Ádám
    • Jan 16 2013 | 6:11 pm
      Thank you very much guys, going to try these now :-)
    • Jan 16 2013 | 6:16 pm
      You guy are legends, all sorted.. Much appreciated :-)