Open patcher without menu bar

    Sep 28 2010 | 10:22 pm
    Hi, I feel like this question must be answered somewhere, but I can't find the answer:
    How do you open a patcher without a menu bar? Basically, something like the "About Max" window. I am trying to make a settings window for my program, and I want it to pop up without the menu bar, because that's quite unnecessary. I've also found that unchecking "Show Toolbar on Open" in the patcher's inspector does not actually hide the toolbar when I open it.
    BTW I am using the "open" message to [pcontrol], which is connected to my settings subpatcher. Using Windows.

    • Sep 28 2010 | 10:38 pm
      I remember a "nomenu" message to thispatcher in the thispatcher help patch...
    • Sep 28 2010 | 11:15 pm
      Thanks! That's what I was looking for.
      I also figured out the answer to the second part of my question: I simply needed to re-load the top level patch in order for toolbar to be hidden in the subpatch.
    • Sep 29 2010 | 9:45 pm
      I wanted to post a follow up to this, because there seems to be a problem associated with it. When I send [thispatcher] the message "window flags nomenu, window exec, savewindow 1," I get a Max window error "method bringtofront called on invalid object when I restart the patch." I can avoid the error by sending "savewindow 0," but then it will show the menu.
      Presumably that is a bug? Is the best option to simply loadbang the nomenu message to [thispatcher], rather than saving the window?
    • Sep 29 2010 | 9:57 pm
      Hi Anthony,
      I can't repro here with a simple patch. Is there perhaps something else going on in your patch?
    • Sep 30 2010 | 12:21 am
      Hi, I can recreate it in a very simple patch:
      Please paste this into a new patcher window, click the message box, save the patcher to disk, close it AND restart Max, then open it again. Note that it only happens if you close Max entirely, i.e. you don't just close the patch, but also close the Max window and other patchers running.
      I'm using Windows 7 64-bit, 5.1.5.
    • Sep 30 2010 | 4:35 pm
      Hi Anthony,
      Thanks for the clarification. I can only get this to happen when launching Max from the patch. This is a harmless error and can be ignored. It should not happen under other circumstances, say, when you open Max first or in a standalone.
      If it really is bumming you out, then a loadbang might be the best way to go at this time.
    • Sep 30 2010 | 5:08 pm
      Moderate bummage, but I think I can manage. :)
    • Sep 30 2010 | 7:05 pm
      One last question:
      I sent the nomenu message to my toplevel patcher as well, but when I make it into a standalone, the Max Runtime window appears on startup, even though I have that option unchecked in [standalone]. Is there any way around that?
    • Sep 30 2010 | 7:17 pm
      Hi Anthony,
      This was actually programmed like this by design. On Windows, if there is no menu then you cannot do anything. So, when max is launched if there are no windows that have a menu, Max always shows the max window to give the user a chance to do something.
      However, it has come up a few times and thus we do have this issue as something to look at down the road.
      A workaround is to add a deferlow between the loadbang and the window message box.
      Apologies for the inconvenience.
    • Sep 30 2010 | 7:30 pm
      That works perfectly, thank you so much for all of your help.
    • Dec 11 2010 | 7:36 pm
      thanks for the workaround !
    • Mar 28 2012 | 1:19 am
      Running max 6 over here. I have a project that I want to use with runtime. I can't get it to run without the toolbar. Could someone please spell it out for me? I have yet to find the right permutation and the client I developed this for just decided they don't want to use display out for their monitor... which was cake to set up. Is the message different on a mac?
      What would be the equivalent of this for Mac? Would the thispatcher need to be in a patcher?
    • Mar 28 2012 | 2:48 am
      did you try View menu-> Patcher inspector-> deselect 'view toolbar' checkbox...?
    • Mar 30 2012 | 12:51 am
      Thank you for the suggestion. Unfortunately, it does not work :(