OpenGL stability issue / freezes / Crashes


    Oct 04 2012 | 6:54 am
    Since a few weeks I have quite a lot of OpenGL crashes (MBP 10.6.8, Max 6.0.7) I'm not sure what causes them but it feels related to these posts: https://cycling74.com/forums/the-visual-freezes https://cycling74.com/forums/bug-crash-when-deleting-pwindow-while-rendering
    For me it happen mostly when opening Gl objects help file +/- copy/paste elements into the patch I'm working on. When I don't add/delete any GL objects, everything is fine.
    Symptoms: Freeze and/or very glitchy window output. Patche freeze, I can't save/edit/change mode. Message: jit.gl.fbo: unsupported framebuffer format.
    I don't have patch to demonstrate but I will try to make one.
    Does anyone has this kind of problems ?
    Thanks

    • Oct 04 2012 | 7:07 am
      yes, it's the same thing as https://cycling74.com/forums/6-0-7-render-problems but with me it's never fine, whith a few slabs in my patch everything tends to freeze and crash big time, most of the time this means restart the whole computer
      Pieter
    • Oct 04 2012 | 7:25 am
      6.0.8 soon ? ;)
    • Oct 04 2012 | 3:09 pm
      hi guys. thanks for the reports. we think we know what's going on here, and will do our best to get you a fix as soon as possible.
      thanks for your patience.
    • Oct 05 2012 | 7:12 am
      that's great news!! On a pure selfish note, I have a performance in 3 weeks, should I start addapting patches to get rid of all things slab/capture. Or is a fix on the horizon?
      pieter
    • Oct 05 2012 | 7:29 am
      i think these crashes are related to deleting jit.window or jit.pwindow.
      if you can describe another scenario where this crash occurs that doesn't involve deleting a opengl window, it would be much appreciated if you can provide a patch and instructions to reproduce.
    • Oct 05 2012 | 7:54 am
      For me it's that: deleting a jit.pwindow or closing a patch with one in it.
    • Oct 05 2012 | 7:24 pm
      If we include "closing another patch with a pwindow in it", it is the case for me. The annoying point is that most of the help files have one ;)
    • Oct 05 2012 | 8:42 pm
      yes, should've been more specific.
      from what i've been able to determine, the crash results when you have a patch with some kind of texture object (jit.gl.slab, gl.texture, gl.node, etc), and you free a pwindow or window object (either by deleting or by closing a patch).
      thanks again for the reports, and we'll get a fix as soon as possible.
    • Oct 15 2012 | 2:12 am
      just offhand posting in the few threads related to this as I find them (they touch on slightly different angles) - editing a patch w/ gl.slab + gl.texture (not just deleting or freeing windows) does it for me. thanks for your work on solving this!
    • Oct 17 2012 | 6:31 pm
      Exactly the same troubles and messages, but even without editing : just let run a patch w/ jit.gl.slab, jit.gl.node a few moments and it crashes !
    • Sep 26 2017 | 9:06 am
      Same problem with max 7.3.4 ...
    • Sep 26 2017 | 3:18 pm
      this is from 5 years ago. if you're experiencing problems please provide a patch, system specs and steps to reproduce.
    • Sep 29 2017 | 9:50 am
      Hi Rob ! Thanks for your answer and precisions... I'm working on a video reverb patch. I followed instructions from delicious Max tutorials : https://www.youtube.com/watch?v=sNr--9LO72k The patch works pretty well, but when I try to erase the jit.pwindow (only when the patch is completed) Max crashes... re openning and trying again does the same crash shutting the system and restarting the mac again doesn't change anything... I am working on a 2016 Macbookpro 13" with macOs Sierra 10.12.6
    • Sep 29 2017 | 3:45 pm
      ok, thanks for the patch and the steps. i can reproduce and will get it logged.