Osc and phidgets external not working windows 7 max 6

    Apr 23 2014 | 5:28 pm
    Hi guys I have a trouble.
    I've been trying many times to get the Cnmat OSC library: http://cnmat.berkeley.edu/patch/4029 and the Phidgets library working in max 6 with no luck.
    I copied the .mxe files in the max-externals folder and the .maxhelp files in max-help folder (I also have .help and .pat files that I don't know where to put)
    but when I search for the objects like: OSC-route in max Patcher; Nothing comes up.
    Its curious that if I open a patch using any of the OSC or phidgets objects; the patch load with no errors but those Objects are still missing or not displaying properly...
    I use windows 7 pro 32 bit with max 6.1.6 32 bit.
    Tried also on windows 8 pro x64 with max 64 but no luck Anyone can help?

    • Apr 24 2014 | 2:31 pm
      I can help you on the Phidgets end. You need to make sure you have the drivers for Windows 32 bit installed on your computer before anything is going to work. That link will also take you through some basic steps to make sure the Phidgets are actually working on your computer, as well as some troubleshooting.
      Then, make sure you have the up-to-date libraries for Phidgets in Max6.
      The final step is making sure that in Options -> File Preferences you have a path to the unzipped folder that you just downloaded with the libraries.
      When you create an object, start typing "Phidget" and you should see a list of compatible Phidget devices show up. If you bring up the help file, you'll see how to read and write to the device.
      Hope that helps with half of your problem at least.
    • Apr 24 2014 | 3:39 pm
      Hi and thank you for the help.
      This is what I done:
      I downloaded and installed the phidgets drivers for windows 32 bit. Downloaded the updated phidgets max libraries Unzipped the file. Took the .mxe files and placed them in The cycling74/max-externals folder Took the .max help files and placed them in the Cycling74/max-help folder
      if I open max, I Open a new patcher and search for an object in the lateral toolbar; none of the phidgets objects shows up...
    • Apr 24 2014 | 3:55 pm
      The Phidgets won't show up in the toolbar. Create an object and start typing Phidget and then you'll see a list of Phidgets (see the attached photo). When you alt-click on the newly created Phidget object, a help file will be brought up showing you how to read from and write to the device.
    • Apr 25 2014 | 2:34 pm
      Yes I done this.
      Created a new object and started to type phidgets but nothing shows up.
      I also tried to point max directly to the phidgets external but still no results. And I get in the runtime: no such object if I try to force the search...
      any help?
    • Apr 25 2014 | 3:03 pm
      Can you open the .maxhelp file from the directory on your computer? When you have that help file open, can you use getSerial or anything? You'll need to make sure that no other applications or processes on your computer is attached to the Phidget. Let me know if that works.
    • Apr 27 2014 | 2:43 pm
      Yes. If I go to the directory and I open the maxhelp file it works perfectly and reads the value.
      Despite this; if I create a new object; it doesn't find the phidgets.
      And its weird because if I instead create a new object in the one of the phidgets maxhelp window; it finds all the phidget objects.
      This is really strange
    • Apr 28 2014 | 3:48 pm
      I would suggest just copying the object from the help file to your patcher. Because the help file will have reserved the Phidget, you'll need to make sure that's closed before trying to run your patch.
      Also be aware that if another program or process is reserving the device then Max won't be able to read from or write to it... but that wouldn't explain why Phidget devices aren't showing up in the object when you start typing.