Patcher Title in HTML file


    Clay Chaplin
    Nov 19 2022 | 6:18 pm
    Hi . .
    It seems that if I comment out the code below the embedded rnbo patch will no longer play on the webpage. Same result in Chrome and Safari. I can comment out the inport, outport, and MIDI keyboard parts and it will still work. I'm trying to eliminate the patch title and verison number at the top of the html page and use something else. Hopefully I'm missing something obvious. I looked in the json and js code but there doesn't seem to be a way to get at the title parameter that is filling in "clay-rnbo1.maxpat (v1.0.1)" and over riding "Unnamed Patcher". Perhaps it is in the compressed mystery code at the bottom of the "export.json" file that is generated? Anyway, is there a way to get rid of the title? Thanks!
    <!-- <h1 id="patcher-title">Unnamed patcher</h1> -->

    • Florian Demmer's icon
      Florian Demmer
      Nov 19 2022 | 8:01 pm
      Hi Clay,
      the template works as a starting point and you can easily modify the code and markup.
      The title is set on this line in the app.js file and taken from the JSON file of the web export
      You can simply delete the line if you don't want the patcher title shown on the page. Additionally there is some HTML markup that you can delete or edit here
    • Clay Chaplin's icon
      Clay Chaplin's icon
      Clay Chaplin
      Nov 19 2022 | 8:47 pm
      Thanks Florian! Commenting out the line in the js or the html does work. It turns out I have to delete all website data from both chrome or safari to get any changes to show up. Reloading the page does not seem to update after any changes to either file. I'm guessing that is more of a js thing or something related to my website, etc. it is sort of a pain but i can work with it. Thanks!
    • Florian Demmer's icon
      Florian Demmer's icon
      Florian Demmer
      Nov 19 2022 | 9:20 pm
      Are you using a local server for development or is this hosted somewhere? This sort of behaviour is related to caching and depending on the setup / stack you are using you might be able to configure this.
      If you are using the npx http-server step from the template repo you can disable any caching on the server using the -c-1 option. Furthermore for development purposes one disable any caching on the browser as well.
      For example in Chrome:
      • open the Developer Tools (View -> Developer -> Developer Tools)
      • navigate to the Network tab
      • enable the Disable Cache option
      This way whenever your DevTools are open Chrome will disable any client side caching
    • Clay Chaplin's icon
      Clay Chaplin's icon
      Clay Chaplin
      Nov 19 2022 | 10:57 pm
      Thanks again. It is on my website which is hosted and running wordpress. The local server works just fine without the caching. What i'm doing might be pretty kludgy since I only have an iframe in a wordpress post that links to the html file. It does work but not sure if that has anything to do with it. I can change the wordpress post info - like change the iframe height or something and simply reloading the page will show the changes. I am logged in on the backend. If I make changes to the rnbo html file or the JS file in nano and reload the page nothing related to rnbo will update until I delete all website data from the browser. I updated the developer tools and disabled the cache as you suggested but i still get the same behavior. It isn't a huge deal and i set the clear browsing data option to just do the cache so it is maybe an extra click or two. I'm not in a hurry to sort this out but thought i would give you a description of what's going on if it useful. There are so many variables in web dev that I'm not sure it is something C74 should worry about. It is really cool to have a simple way to post max patches on a website so I can totally deal with this.
      Of course - just click post to this and then tried reloading the page and it worked. I think there is some sort of timeout issue going on on the server side of things. It seems if I wait for about 7 to 10 minutes then simply reloading the page will update it. I'll poke around more . .
    • Calum Vaughan's icon
      Calum Vaughan's icon
      Calum Vaughan
      May 11 2023 | 10:46 pm
      Did you ever get to the bottom of this? I have the same problem, and was baffled because I couldn't find patcher-title in any file yet if if removed this h1, everything died. I couldn't figure it out and ended up making the h1 transparent and am now pretending its not there haha