Percolate for max5 (mac) ?


    Apr 13 2011 | 1:24 pm
    hi
    is there a percolate for max5 (on Mac) installer? When looking for it on the percolate (old ?) web page, there were only Max4.x installers..
    a link?
    many thanks
    kasper

    • Apr 13 2011 | 2:00 pm
      Hi Kasper how are you? One week ago i post a topic about Percolate, the response, was : you must recompile it with source code for max5 on mac. So some externals works like a charm abmin, absmax, munger, I don't use more objects
    • Apr 13 2011 | 2:05 pm
      oh, thanks.....
      yes, just trying some of them Percolate objects max crashed...
      So i gues the next question is - did anyone recompl-iled percolate for Max5? could anyone do it?
      thanks again
      kasper
    • Apr 13 2011 | 3:12 pm
      Dear Kasper,
      Actually nobody recompile it on mac . But could you tell me which object you encounter a max crash maybe I try to recompile it, it's a challenge for me. And in addition to this message, actually just one person recompile Percolate for Windows, not for Mac. Maybe it's possible for researcher like Jamoma team concepts of Percolate change with scientific knowledge maybe their objects are deprecated actually.
      But code is open, MaxMSP SDK 5.1.8 is disponible now I have xcode on my macbook I wouldlike to compile them. I try it.
    • Apr 13 2011 | 3:17 pm
      ok, thanks
      i actually was just trying some stuff (I still mainly use max 4, and am moving to 5 - I don't know why since , as far as I know, the audio engine is just the same..........) and got some crashes
      yes, munger works
      have still to try some more
      best
      kasper
    • Apr 13 2011 | 4:21 pm
      I believe all the PeRColate objects work with Max 5 -- I just tried a random assortment from the help patches and they all work. Just move the object folder into a max-search-path directory and restart.
      I'm running Max 5.1.7 under OSX 10.6.7, MacBook Pro.
      brad
    • Apr 13 2011 | 4:33 pm
      Kasper
      What is your Os? 10.5 or 10.6?
    • Apr 13 2011 | 9:40 pm
      I did not try them all, but blow_hole.help crashes my max every time
      latest max, mac 10.6.7 (mac book pro intel i5)
      the help and the objects are in the search path
      best
      kasper
    • Apr 13 2011 | 9:40 pm
      I did not try them all, but blow_hole.help crashes my max every time
      latest max, mac 10.6.7 (mac book pro intel i5)
      the help and the objects are in the search path
      best
      kasper
    • Apr 13 2011 | 9:42 pm
      sorry for the duplicates - don't know why it happened
      k
    • Apr 13 2011 | 10:36 pm
      Yes Kasper for me it's a same result blow_botl~ and blow_hole~ make a max crash.
    • Apr 13 2011 | 11:15 pm
      Hi,
      It works fine here :
      MaxMSP 5.1.7
      macosx 10.6.7
      2 X 2 Ghz Dual-Core Intel Xeon
    • Apr 14 2011 | 8:03 am
      and which percolate installer do you have? could you share it? (on some ftp or otherwise)
      thanks you
      k
    • Apr 14 2011 | 8:45 am
      Hi Kasper
      (we met a long time ago at CCMIX ! )
      A bientôt
    • Apr 14 2011 | 1:34 pm
      There is no "installer" per se. This is from the README.rtf file included with the download (perhaps it's worth reading?):
      Copy the PeRColate_UB folder AND the PeRColate_support folder into your Max support folder (./Cycling'74).
      Copy the PeRColate_help folder into the max-help folder of your Max distribution.
      Copy the PeRColate_overview.pat and percolate.jpg files into your 'extras' folder.
      I checked the objects, they're working for me.
      brad
    • Apr 14 2011 | 8:35 pm
      @ Brad
      yes, i understood (and saw) there is no "installer per se". To put my question in a more formal way I asked "which distribution did you use, since you have all objets working fine ?"
      for instance i don't have the peRcolate_support folder......
      my install (folder) was named PeRcolate-OSX-Intel-10.5
      (and no READMA.rtf neither)
      thank you
      kasper
    • Apr 14 2011 | 9:35 pm
      Ok, I wasn't sure where the confusion was.
      Download the lastest:
      NEW PeRColate 0.9 beta 6 for Max 4.6 (OSX Universal Binary) (8.8mb)
      and unpack it. All the files (including the README.rtf) should be there. I just did it myself and they are intact.
      brad
    • Apr 14 2011 | 9:36 pm
      oops, I meant "latest" not "lastest"
      brad
    • Apr 15 2011 | 8:26 am
      thank you Brad
      I did download the version you pointed - but can't say it's much much better
      _when reading the README.rtf it says (as you pointed) : "Copy the PeRColate_UB folder AND the PeRColate_support folder into your Max support folder (./Cycling'74)."
      ok, but when the objects ( PeRColate_UB folder) are there, max does not see them (OK, I could include it in the search path) - I moved them in my "3rd party externals" folder
      Now it works ok, BUT, as before, blow_hole.help crashes max the moment I launch it. Does this help file work OK on your computer?
      many thanks
      best
      kasper
    • Apr 15 2011 | 9:36 am
      Kasper
      Actually it's my version on my computer so blow_botl~ and blow_hole~ make a max crash. When I open a source code some errors appears in the script, but I'm not Coder in C, I try to resolve a problem of compilation now... in xcode4. But no tutoriel is clear on this topic, or show how must you can do it step by step. I can tell you I'm really near to do that but one question need to be resolved.
    • Apr 15 2011 | 12:06 pm
      @mortimer59 Regarding your comment about the possibility of the Jamoma team incorporating aspect of Percolate, there isn't much we can actually do. Percolate is distributed with full source code, which is really awesome, but the license is not a open source. For any inclusion into Jamoma itself, things we draw upon must be licensed at least as liberally as the BSD license.
      Cheers,
      Tim
    • Apr 28 2011 | 3:46 pm
      I'm also finding saxofony~ crashes Max in its New method, calling sysfile_geteof(). I've also had crashing on the blow_hole model. This is on Max 5.1.{7|8} on current Snow Leopard (10.6.6).
      I took a quick stab at rebuilding saxofony~ with XCode 3.2.1, but there have been a variety of issues. I tried updating the STK library to the latest version, but that also seemed to be a can of worms. It looks like some of the class implementations have been moved from .cpp files into the .h files and other restructuring. It would be _extremely_ helpful if someone who actually knew how the bits and pieces are supposed to fit together could take a look at this stuff. Percolate is awesome (despite the fact that no one can ever remember the canonical intercapitalization:-) but it would be a lot more awesome if the entire package worked reliably under Max 5.-|
      I should add that I'm working with what seems to be the most recent Percolate, which calls itself Percolate_06.
    • Apr 28 2011 | 10:58 pm
      glad you answered to/in this post, Peter !
    • Apr 30 2011 | 2:21 am
      Peter did you try to rebuild externals with xcode 4? ì build this external but it 'a same result. Max crash....
    • Oct 01 2011 | 10:54 am
      Kasper, could you tell me your email I can send you know this object.
    • Oct 01 2011 | 12:30 pm
      Hi
      Try
      All appear to work as is - i7 iMac 10.6.8 Max5.1.9
      MM