Performance problem

    Oct 18 2010 | 6:39 pm
    I don't know much about hardware, but how it's possible that my old iMac runs my patch faster than my new MacBook Pro?
    I have been doing multimedia installation with Max/MSN/Jitter and basicly it's just mixing video clips with real-footage from USB-camera. I'm using GPU for video stuff and CPU is for some other smaller tasks.
    Ok, sounds simple and works great, but now I have this weird performance problem when I try to run my patch in a other computer.
    I made my patch with old iMac (2 GHz Intel Core Duo, RAM: 2 Gt, ATI Radeon X1600) and it works great there. I get someting way over 25 fps and that's enough for me becase, I just need that 25 fps. Well, but when I run my patch with my new MacBook Pro (2,26 GHz Intel Core 2 Duo, RAM: 2 Gt, NVIDIA GeForce 9400M), I just get something around 15 fps.
    Any idea, what is wrong?

    • Oct 18 2010 | 7:23 pm
      In my MBP the 9400M uses "shared memory" which means RAM rather than dedicated VRAM for 3D acceleration. Some MBP's have the option to switch to the "high performance" 9600M GT - check in your Energy Saver system pref. If you have this option it will say:
      Graphics: * Better battery life * Higher performance
      Choose higher performance to use the 9600M.
    • Oct 19 2010 | 7:07 pm
      Oh, I couldn't find that option. I tried to find is there any other way to switch that option, but it seems it's not possible in my MBP. Thanks anyway!
      It seems one node (just using tp.slide.jxs) is causing that significant performance drop down in my patch. When I took that off or I just used CPU to perform same task, it worked really fast. I kind a solved my problem at the same time, but I'm still wondering why that is still working better with my old computer.