PGM2CHAIN-Midi Effect not workin Live 11


    Sep 14 2021 | 10:44 pm
    Hi!
    I'm looking for a hint how to update a device like this for using it with live 11: https://maxforlive.com/library/device/6356/pgm-to-chain-midi (this is not my device, but I could badly use this for my festival gig this weekend, so I thought fixing it by myself as the origina author does not seem to active at the moment)
    I looked in the m4l-api and the path to the chain seem to be the same with the pre-11 api, but something is not working out here. I have only basic knowledge of m4l, but I can think I could manage it with a few tips ^^
    Thanks and greetings
    Sebastian

    • Sep 15 2021 | 8:17 am
      Hello, Ableton changed the parameter number of the chain selector in L11 because they are now more macros.. It was "paramerer 9" in L10 and it's now "parameter 17".
      Cheers ! =)
    • Sep 15 2021 | 8:22 am
      Hell yeah, thank you very much :) It works ^^. I already tried some other parameter numbers (8, 10, 11) but did not have the idea of taking the new macros into account. Where can I find information like this - I seem to stupid to access the proper documentation :)
      Cheers
      Basti
    • Sep 15 2021 | 8:29 am
      glad to know it's working ! ..I found that the eaisier way to know what is the parameter number is to use the free device "where am I" on maxforlive.com. Just select any parameter and device gives you the id and the path.. it's an old device but it's still working good !
    • Sep 15 2021 | 8:35 am
      Ahh, great hint - the device is still working. Will keep that in my library, thanks a lot for helping out. This will make my fusion-liveset-preparation a little bit easier :D