Phidget interface

    Dec 06 2011 | 8:56 pm
    Hello guys, for a project i am doing i need max to accept incoming data delivered by this device:
    Whats the easiest way of doing this? Im a complete max noob by the way but am really interested in learning it. I had tried installing a driver i was directed to etc but i just couldnt get it to work. There will be a couple of IR distance sensors amongst other continues inputs.
    Any help would be mega chilled of you,

    • Dec 06 2011 | 10:43 pm
      Go to this page if you haven't already:
      The 'getting started' .pdf for Max explains that the externals required are bundled with code examples, hopefully that should talk you through it. I looked at these a while ago but went with Arduino in the end, let us know how you get on.
    • Dec 06 2011 | 10:58 pm
      cheers mate! will have a look at that now, will let you know
    • Dec 06 2011 | 11:56 pm
      Should a .mxo file open in max? keep double clicking it and nothing happens
    • Dec 07 2011 | 12:58 am
      create a new object and type the name of the mxo file in it. Make sure it's in your search path
    • Dec 07 2011 | 1:15 am
      Oh my god, never has a piece of software made me feel so stupid haha. Sorry i dont know how to set a search path, i have tried just double clicking the mxo file but it says "PhidgetInterfaceKit: unable to load object bundle executable"
      Im running max 5 btw.
    • Dec 07 2011 | 1:17 am
      ahh... and it then says "Reason: image not found"
    • Dec 07 2011 | 12:44 pm
      Just had a peek at the readme that comes with the Max code examples and it pretty much explains how to install them. Take your time and get an idea of how it all works. Here's a link to the documentation explaining the search path:
    • Dec 07 2011 | 12:49 pm
      Mmm I've actually just tried it myself and been given the same errors, I haven't installed the Phidge21 libraries though, I don't know if that makes a difference or not.
    • Dec 07 2011 | 2:32 pm
      Yeah iv read that and followed it... weird, the folder is certainly listed in the search path's too. Ahh well, will have to just keep clicking buttons and such
    • Dec 07 2011 | 3:18 pm