poly~ headache


    Nov 26 2011 | 3:17 pm
    excuse my bluntness but why the hell is this not working??
    makes no sense.... bet its something to do with the float object.
    sorry cant work out the text clipboard thing.

    • Nov 26 2011 | 4:03 pm
      Hi there,
      Try to initialize the poly~ with a @target 0 argument, so that the midinote message gets sent to all instances (it will take care of the targeting itself based on busy-state).
      Also take out the *~ from inbetween the gain-slider and the output. It's multiplying the signal by zero so you'll never hear it.
      Hope that helps...
      antwan
    • Nov 26 2011 | 6:07 pm
    • Nov 27 2011 | 10:08 pm
      hi antwan, what do you mean initialise the poly~ with @target 0 argument. sorry if i'm a bit thick, i'm just learning.
      thanks chris for the text edit help.
    • Nov 27 2011 | 10:23 pm
      hi I added a target 0 but it didn't help, i cannot see at all how this is not working??!!???
    • Nov 28 2011 | 2:15 am
      for future reference, both the top level patch and any included patch (in this case the poly~ patch) need to be included.
      Here's the top level patch, which works for me.
    • Nov 28 2011 | 6:25 am
      Hey,
      Yeah, that should cut it.
      ( What I specifically meant - which is practically no different then what you did - was just to type in @target 0 into the poly~ object box after @steal 1. I.e. initializing the object box with the attribute target 0. )
      If it still doesn't work, just double check that you have the right midi input selected for notein (i.e. that you are in fact receiving notes) etc and if still in trouble do copy/paste once again both patchers so we'll have a look.
      Regards,
      antwan
    • Nov 28 2011 | 10:11 pm
      man, thats amazing. thank you. can i use a line~ object within the poly~ to stop the clicking? this is the only issue now... :-P
    • Nov 28 2011 | 11:03 pm
      sure thing. or adsr~ could also be a good option considering held notes from the midi input. good luck!
      a
    • Nov 28 2011 | 11:49 pm
      You already have an adsr~ in the poly~ patch you're just not giving it any values, so it's clicking. Here's the Polyvoicemulti patch:
      and here's the top level patch:
    • Nov 30 2011 | 7:35 pm
      thanks Chris, I appreciate the help. I shall have a look at this when i get home.