poly~ sudden silence

    Jul 10 2012 | 10:49 pm
    Hi! I have a very strange thing that happening on a MFL device I working on :
    - the device contains [poly~] - the device works fine - if I load two instances of the same device, suddenly (and randomly, after max 5 minutes), one of them stops producing sound!! - if I look in the silent [poly~], apparently there's no more signal working - sending a "mute 0 0" message to the silent [poly~] restart the audio… - …until next sudden silence (soon!)
    I tried a lot of things, and finally I found that a Max [poly~] tutorial patch, if "ported" as device (with same handling method as in my device), have the same problem!! BUT, if you look for example at MFL Pluggo Big Ben Bell, well, it's almost the same, and it works!!!
    what I mean with "handling system" in these devices : - no [adsr~] - trig + "mute 0", then [line~] bang to "mute 1"
    Nooow, I'm pretty sure I'm missing something (maybe something really stupid), but I really don't understand what!! It's driving me crazy! Please… any suggestions?
    I'm working on Max 5.1.9 / Live 8.3.2
    I took a look on the forum (and MFL section on Ableton forum too), but I can't find a solution :(
    the poly~ for the attachement is installed with Max : littlebleep2~

    • Jul 10 2012 | 11:37 pm
      ...if you can't reproduce the bug (sometimes this happens), try with shorter metro values. 20
    • Jul 11 2012 | 6:01 am
      I was getting this behavior last week while working on a current project. I had a defer (or a deferlow, I can't recall) in there somewhere. Pulling it out resolved the problem.
    • Jul 11 2012 | 8:34 am
      Hi amounra thanks for your suggestion... but there are no defer/deferlow in this patch :( ... the mystery remains...
    • Jul 11 2012 | 6:30 pm
      Yeah, I noticed that when I checked out your patch last night. I installed 2 of them and let them run for a half hour or so while working on other stuff in my Live set....unfortunately, I couldn't reproduce the behavior you're reporting :(
    • Jul 12 2012 | 9:33 pm
      thanks for your help! I'll try to clean up my device and I'll post it here asap...
    • Jul 13 2012 | 5:50 am
      here's a new device... on my computer it takes max 2 minutes to reproduce the "sudden silence" thing.
      MacBookPro, OSX 10.7.4, i7 2.66 Ghz, 4Gb Ram.
      note : the problem arrives also with @steal 1...
      thanks in advance!
    • Jul 17 2012 | 2:29 pm
      Hello, I can confirm this behavior. BUT, have you tried this with disabled ableton multiprocessor setting ? It seems that M4L and poly~ don't work well together with the multiprocessor support of ableton.
    • Jul 19 2012 | 3:54 pm
      Hi Stan thanks a lot for your reply...I'm going to try this tonight!
    • Jul 20 2012 | 12:50 pm
      Hey Stan it works!! Thanks a LOT! I'm going to check your post...