poor fullscreen resolution


    Apr 18 2013 | 5:09 pm
    Please help a new guy. I can't get high quality fullscreen movie. Using 1920 x 1080 QT mov file as source. Trying to get fullscreen (2560 x 1440) picture - it looks a little pixelated. What inspector settings do I use? Or is the problem else where?

    • Apr 18 2013 | 5:28 pm
      a little or a lot? if it's a little you're probably looking at the upscaling of 1920x1080 to 2560x1440.
      a lot then jit.qt.movie is probably still set to the default 320x240
    • Apr 18 2013 | 5:38 pm
      Thanks for your reply. I guess a little, but it seems to be more pixelation than if I play the source movie fullscreen directly, i.e. double clicking the qt file. That is my concern. The jit.qt.movie is set to 1920 1080 in the inspector.
    • Apr 18 2013 | 9:48 pm
      Quicktime player might be filtering the video to make it smoother and jit.qt.movie doesn't. Hard to say without seeing what you're seeing. How about some screenshots or so?
    • Apr 26 2013 | 12:16 pm
      Hi
      I have the same problem. Did you find a solution??
    • Apr 26 2013 | 3:34 pm
      Try "@adapt 1" parameter of the [jit.qt.movie] object. Next use [matrixinfo] object to check resolution of the matrix produced by [jit.qt.movie]. If resolution is ok - check rendering parameters (interpolation, fsaa, smooth_shader, etc.).
      And - of course - you can post your patch. Sometimes it's simplest way to discuss possible issues.
    • Apr 26 2013 | 3:53 pm
      Thanks
      The resolution is ok. 1280/720 codec : Apple proRes 422
      Can you tell me more about the interpolation, fsaa, smooth_shader?
      My patch is very simple but when I compare my video played with jitter and the video played with quicktime, I can see more pixels.
    • Apr 26 2013 | 4:09 pm
      I don't know, haw you displaying the video. I guess you are using [jit.gl.render], [jit.window] and [jit.gl.videoplane]. Play a bit with antialias and fsaa parameters of [jit.gl.render], antialias, interp, and smooth_shading of [jit.gl.videoplane], interp and fsaa of [jit.window]. Try switch to "1" all the mentioned parameters.
    • Apr 26 2013 | 4:10 pm
      "haw"... hehe sorry.
    • Apr 26 2013 | 4:25 pm
      Not all.
      It's my really simple path.
    • Apr 26 2013 | 7:20 pm
      Dear Nanor
      Try attached basic patch.
    • Jun 17 2015 | 2:28 pm
      Ah...thanks for that info people.