Problem outputting bag-data


    Oct 10 2013 | 9:13 pm
    i have a note-in that is connected to a bag, storing all notes that are currently held (and removing the ones i release). Whenever i send a bang message (or a 'length'-message) to the bag, it will only output the result when i release the notes - there is no output at all when holding the notes, it's all being buffered and outputted afterwards (playing on a keyboard).
    Am i doing something wrong here?

    • Oct 11 2013 | 9:47 am
      don't know exactly what the problem might be without a patch posted, but it sounds like you should look at [borax]-- it may provide the solution you're looking for
    • Oct 11 2013 | 10:12 am
      Thanks, borax seems to be exactly what i want. i'm still curious as to why the bag wouldn't output anything while i was holding keys down. The problem was as follows:
      • bag object storing all notes with vel > 0, removing those with vel == 0
      • length message that goes to the bag, clicking it outputs 0 (initially), which is correct
      • i hold down keys on my midi-keyboard, and while doing that i click the length-message to check if it's indeed being stored in the bag: nothing happens, no ouput
      • whenever i release the keys, the bag outputs the length (if i clicked the length message 5 times during holding down the keys, i get that output 5 times after release
    • Oct 11 2013 | 10:48 am
      sounds like a message-ordering problem-- without posting a patch can't really know for sure-- you can also use the debugger to check whats going on