problem with jit.gl.render on IMac G5


    Apr 26 2006 | 2:47 pm
    Hello, Jitter-folk,
    I am writing with regard to a problem I'm having on a recently
    purchased IMac G5 (PPC, NOT intel) 2.1GHz 21" machine.
    I'm running a previously created patch that worked fine on a Powerbook G4
    1GHz / 1.5GB RAM.
    Now I'm trying to work on it on a new IMac G5 2.1GHz / 1.5 GB RAM, ATI
    Radeon x600 XT
    Both machines have Jitter 1.5.2 installed.
    With the Powerbook test-run, all works fine,
    > jit.gl.render: building GL on window "Sonic_Subway_Map"...
    ... commences and the project is OK.
    With the new IMac test-run, I get:
    > jit.gl.render: building GL on window "Sonic_Subway_Map"...
    then
    >jit.gl.texture: setting texture target.: GL Error: Invalid value
    jit.gl.texture: setting subteximage during submission.: GL Error:
    Invalid operation
    Since nothing has changed besides my machine here, I'm confused. I've
    sent this "isolated problem" patch to others and it works on their
    powerbooks:
    max v2;
    I can send the image as a personal e-mail attachment to anybody who is
    able to help since I'm not sure how the list feels about attachments.
    Perhaps someone knows the answer to this mystery? Time is of the
    essence as this is going to be part of an
    installation that begins in a week and a half!
    Cheers,
    Jim Briggs

    • Apr 26 2006 | 2:59 pm
      I had this problem recently, and I solved it by changing the
      dimensions of my texture images.
      I don't know what exactly is the problem, but I guess it has
      something to do with proportions or multiples of 2 pixels width/high...
      So not exactly sure, but that 'did' solve it for me. If someone can
      shed more light on this, i'd be happy to know this as well...
      regards,
      brecht
    • Apr 26 2006 | 6:39 pm
      Hey,
      could you send me the file you use in this patch ?
      Interested to check what the problem can be...
      grtz,
      Brecht.
    • Apr 26 2006 | 6:47 pm
      I just located my problem and it was with quicktime, actually. I did a
      re-install up to the latest version and it solved everything.
      I noticed when going back to the help that the movies either weren't playing
      or were acting funny when I loaded them up in help.
      Nice to know it wasn't my new machine or max inabilities. ;)
      I can still send the image if you'd like, though.
      Cheers,
      Jim
    • Apr 26 2006 | 7:09 pm
      Well... I guess that wont be necessary :) Good to hear you managed to
      solve it.
      I did have the problem with the jit.gl.texture objects when loading
      in certain files of certain dimensions which seems to be related to
      the hardware.