Problems with Brad Garton objects

    Oct 31 2010 | 10:06 am
    I would really like to get chuck~, rtcmix~ and sc3~ working but am having problems installing them.
    They are going where they need to be, but just not being recognised as objects. I have tried several times and at one stage rtcmix~ was recognised, just not functional so I stripped them out and put them again in the appropriate places (Cycling '74/msp-externals) with no recognition at all.
    I am using 5.1.5 on 10.6.4 and would really appreciate any advice, ideas or help please.
    Whilst searching I did see that some IRCAM stuff may have been a problem if previously installed, which was the case however I am pretty sure that I have got rid of it.

    • Oct 31 2010 | 4:21 pm
      Well, All of these have one very different installation issue: they require that all the files sent with the distribution be available within the Max/Msp search world: usually the Cycling74 folder by default. So when you install these, make sure that ALL files in distribution are in the Cycling74 folders. For ease of maintenance (vis. updates), just go ahead and place *all* the files of the dist. in a folder of their own in the externals directory.
      Just a guess as to what is wrong: your description sounds like what happens when the mxo files ONLY are found by Max/Msp...these need *all* those files sent in the dist. Just a guess, good luck! j2k
    • Nov 01 2010 | 6:15 pm
      and if you put them into a folder in the C74 externals folder, you'll need to type the name as folder.externalname, like the jitter objects: jit.pwindow, or double-folders, like,,, etc.
    • Nov 02 2010 | 9:09 am
      Hi You don't need the folder.external name; and etc are just standard objects in the c74/jitter folder. We are in mxj so the nearest thing is net.tcp.send which has that path within the classpath. Don't confuse the issue.
      Add a folder to Max5 called Addons, and add it your maxpath via options>file preferences, selecting subfolders. Drop the folders for each of these packeages into this folder You can also make a AddonHelp folder and do the same with the help stuff. This keeps things a little more under control in my mind once you have added several external packages.
      So reread the help and the instuction with the installs and make sure you have the proper up to date version as well And try again. Send a more informative report of what happens if you have further problems. Cheers MM
    • Nov 02 2010 | 1:40 pm
      Hi All
      Many thanks for the ideas, really stumped though. I have checked and double checked that I have the latest versions and they are installed in the correct places and just get a no such object message when attempting to instantiate them.
      I tried it on a colleagues laptop with a fresh install of Max (and putting the objects in the same places) and they all work fine, so it is obviously something to do with my system.
      Is anyone aware of anything that might conflict with these objects and how to get rid of anything that does?
    • Nov 03 2010 | 5:46 pm
      Wow, tough one!just another idea: Do a thorough search for existence of some other copy of the externs themselves: I have had Max find a broken install I did not even know was there...removed it, and the correct versions were found , and all was ok...
      Good luck!
    • Nov 04 2010 | 7:21 am
      Maybe check 'permissions' and 'open with' settings for the various files . Also check if any system errors are logged in console. Cheers MM
    • Jan 09 2011 | 2:50 pm
      Hi all.
      I'm having the same problem as Algie, was wondering if this had ever been resolved at all. I'm running Max 5.1.3 and OSX 10.6.6.
    • Jan 31 2011 | 11:35 am
      Apologies for the delay in getting back to everyone, I have been having some forum related troubles.
      As far as the objects mentioned above go, nothing seemed to work and in the end I just went for a reinstall. Problem solved, rtcmix~, sc3~ and chuck~ now all work fine. I didn't put any IRCAM objects back in so I cannot confirm that this was anything to do with the original problem, in fact to be honest I am completely at a loss as to why they didn't function.
      However all is now sorted for me and hope the info might help someone else.
    • Jan 31 2011 | 5:08 pm
      Reinstall of max/msp, or just my objects? I have a new release of all the object (mac only for now I'm afraid, windows coming later) in the next day or so. I wat to be sure they're happy, I think this has something to do with teh mysterious Info.plist and pkgContents files. arg. Apple.
    • Jan 31 2011 | 7:46 pm
      Full max/msp reinstall. A bit of a pain, but it got everything working in the end.
      Thank you very much for the objects by the way.
    • Jan 31 2011 | 8:00 pm
      I think I found the trouble causing this on some systems. The new release(s) should have it fixed.