problems with Cosm package

    Oct 19 2010 | 4:34 pm
    is there someone who could tell me if i'm wrong,
    but i just downloaded the Cosm package ( and it seems that some externals are missing : cosm.query, cosm.field.query ...
    I tried all the different versions but those externals are still not there.
    Maybe some parts of the package now are useless, but it is not mentionned on the website...

    • Oct 19 2010 | 5:56 pm
      No problems here. I used the Mac OSX installer. cosm.query shows up, but I have to type it in manually (i.e. it doesn't appear under autocomplete). I'm a student of these guys at UCSB, so if one of the installations is actually missing externals, I could tell them directly for you.
    • Nov 06 2010 | 8:27 pm
      This was an issue reported about 9 months ago:
      I have no trouble creating an object like cosm.query in a Max patch but I'm not able to create a collective or standalone that incorporates these objects (although creating a collective and opening in a full version of Max does work), presumably because they're not actually included as separate externals in the cosm package.
      According to the post mentioned above, the issue has been reported already. However, thelizard, it would be great if you could mention this to Wes and Graham. Thanks!
    • Nov 17 2010 | 5:39 am
      Does anybody know how to automatically load an external (cosm.mxo) upon opening Runtime and/or a standalone? Placing it in the max-startup folder doesn't work.