problems with filterdesign+cascade~


    Oct 29 2011 | 9:04 pm
    Hi all,
    I just noticed two nasty bugs on filterdesign with cascade~, at least on my machine (MBP Core2Duo 2,16GHz, OS 10.6.8):
    1/ after opening the the patch below, which is an excerpt of filterdesign's help file, when I switch on the dac for the first time, the output of cascade clips, and the peakamp shows a "Inf" value:
    Sometimes the problem does not occur, I was not able to understand in which conditions. But I found the way to make the problem appear again, by doing this:
    . open the previous patch and switch on the dac. If the problem does not occur, then...
    . alt-click on the filterdesign box in the patch to open the help file
    . close the first patch, leaving only the help file open
    . switch on the dac: normally, this creates the "inf" clip again
    Sorry not to be able to provide a simpler way to achieve this bug.
    2/ Another problem, maybe related, occurs when the order is changed from a small value to a higher value: there is a short peak which amplitude depends on the difference between the new order and the previous order. For instance, if the order is changed from 2 to 50, the output clips and the peakamp~ shows a value around 50.
    Alexis

    • Nov 10 2011 | 1:44 pm
      Hi,
      Exactly the same thing here with Max 6.0.1
    • Nov 10 2011 | 9:59 pm
      Same here, except with a filtergraph~ feeding the cascade~.
      I sent a bug report to support [at] cycling [dot] com. Would've used the bug report form but didnt seem to have the option to attach files.
      Hope it helps to get it sorted.
      Br,
      antwan
    • Nov 10 2011 | 11:53 pm
      confirmed. We'll have a look into this, thanks for the report.
      -Dave
    • Dec 12 2011 | 10:02 pm
      Any progress on this Dave? It's been happening a lot to my filters.
      thanks,
      Ian
    • Dec 12 2011 | 10:15 pm
      This has been fixed for our forthcoming Max 6.0.2 release.
      Cheers,
      Tim
    • May 17 2012 | 12:39 pm
      cascade~ is actually still problematic in 6.0.5
      Nicolas