Pure sine is distorted (the newbie asks ...)

    Feb 10 2014 | 10:33 pm
    Hi there,
    I'm on a trial version of Max 5, finally finding some time to get my head around it. I'm familiar with programming languages and audio technology so my beginnings feel quiet alright.
    Working my way through tutorials I noticed, that my computer does things differently. The attached example should produce a pure sine wave at 0.75 of "the volume". However, the signal shown in the scope displays something else.
    How can this be?
    I'm pretty sure its not my configuration since I run on one of them superfast new macbook pros. Other audio software (DAWs etc.) work just fine.

    • Feb 10 2014 | 11:06 pm
      Hi . its a scope settings . it truncates display frequency . check samples per pixel settings (lower the size)
    • Feb 10 2014 | 11:08 pm
      really? but it doesn't really sound like a sine wave either. also: the guy in the tutorial didn't do anything with the settings. By default, the range is -1.0 to 1.0, right?
      I'm gonna double check that now (watch it again ...)
      EDIT: its not a sinewave. it sounds as weird as it looks
    • Feb 10 2014 | 11:11 pm
      no ?
    • Feb 10 2014 | 11:18 pm
      post a patch :D cant believe . maybe your soundcard ? double check its output
      here is mine
    • Feb 10 2014 | 11:23 pm
      It's an anomaly of the scope~ object. Open the inspector for scope~ and change the "calcount" field to a really low number like 4. Calcount determines the number of samples represented by each pixel on your monitor. With high frequencies AND high calcount values, you will get this sort of aliasing in the scope~ display. The audio is working fine, it's just the visual representation that's weird.
    • Feb 10 2014 | 11:27 pm
      Also, make sure your message values are connected to the right inlet of *~ not the left.
    • Feb 11 2014 | 8:25 am
      you guys are great! both solutions did work. Its a proper sine wave since I've changed the callout function (thanks BKSHEPARD!). Also, your patch worked right from the start DO...WHILE!
      Before I did that, I've uploaded this video: https://vimeo.com/86393001 which is accessible with the password "msp". You can see "the bug" when I'm opening the patch in Max 6 runtime and then in Max 5 trial.
      Now I can go on with my learning ... after a full day of work :/
      Thanks again folks!
      EDIT: I just couldn't go on with the lessons because this essential part didn't work. I'm still not sure what I have learned from this. Probably that there are "anomalies" in some components? I'm not sure ...