Re: [max-msp] ?Bug? in jit.gl.render external?!


    Apr 23 2006 | 10:00 pm
    I am wondering if any other M/M/J users have experienced the problems
    I am having here. Below my message, I have quoted a prior poster to
    the max-msp list who had a similar (but not exactly the same) problem
    to the one I am having.
    Running a previously created patch that worked fine on a Powerbook G4
    1GHz / 1.5GB RAM.
    Now I'm trying to work on it on a new IMac G5 2.1GHz / 1.5 GB RAM.
    Both machines have Jitter 1.5.2 installed.
    With the Powerbook test-run, all works fine,
    > jit.gl.render: building GL on window "Sonic_Subway_Map"...
    ... commences and the project is OK.
    With the new IMac test-run, I get:
    > jit.gl.render: building GL on window "Sonic_Subway_Map"...
    then
    >jit.gl.texture: setting subteximage during submission: GL Error:
    Invalid operation
    I'm not using [jit.gl.texture] so I'm quite confused. And since
    nothing has changed besides my machine here, I'm further confused.
    Can anyone else speak to or offer solutions to this issue? Like the
    previous poster, I need to be ready for this in a few weeks, and am
    anxious to get all bugs fixed and gloss up the installed product.
    Thanks a million,
    Jim
    On 11/25/05, bart wrote:
    > Hi, Jitter people,
    > I use now MaxMSP4.5.5/Jitter1.5.2 on a Powerbook G4 1.5 GHz / 512MB ram
    > / 64MB vram.
    >
    >
    > I think that there is a problem, ?bug? in jit.gl.render external
    > because in the same patch:
    > In MaxMSP4.5.3/Jitter1.2.3 > NO GL Errors, my patch worked nice
    > In MaxMSP4.5.5/Jitter1.5.2 > GL Errors with textures but no crash,
    > textures in my patch are not visible anymore!
    >
    >
    > Max window shows GL Errors:
    >
    > jit.gl.render: building GL on window "Backworld"...
    > jit.gl.render: building GL on window "BeatTheSabbath"...
    > jit.gl.texture: setting subteximage during submission.: GL Error:
    > Invalid operation
    >
    > and
    >
    > jit.gl.render: building GL on window "Backworld"...
    > jit.gl.render: building GL on window "BeatTheSabbath"...
    > jit.gl.texture: error binding texture to target: GL Error: Invalid
    > operation
    > jit.gl.texture: error entering unbind: GL Error: Invalid operation
    >
    > but i don't use this jit.gl.texture external in my patch!
    >
    > This error gives this problem:
    > > Textures are in Jitter1.5.2 not on every 3d model visible like before
    > with Jitter1.2.3 where it worked properly.
    >
    >
    > I think that there is a problem in the jit.gl.render external in
    > Jitter1.5.2 because of this changes:
    >
    > - jit.gl.render: now uses jit.gl.texture internally. use sendtexture
    > message to send messages to the texture set by usetexture
    >
    >
    >
    >
    >
    > I hope you can find a solution and fix this ?bug? because i have to do
    > a performance with this patch in two weeks.
    > Thanks and regards, Bart
    >
    >