Reason 5 , rewire error-

    Jan 01 2011 | 3:21 am
    Happy new year!! a little help?
    ok, so I followed the instructions from (ReWire Essentials, Part Two) and After locating my devices every time I load reson I get errors, whenever I load ad_rewire in the dsp menu I also get errors, I have tried opening reason first and after and no go, this is very disappointing, I am trying to find a way of controlling knobs and numbers of my reason instruments via max msp and don't know what else to do, I even tried reinstalling rewire 1.7 nothing changed.
    what could be the problem

    • Jan 01 2011 | 11:54 am
      Hi using your own soundcard driver, can you access and use the [rewire~] object's helpfile? 1. create [rewire~] object 2. open helpfile 3. follow steps 4. launch reason 5. initialize audio
      works ok here, Max 5.1.2, Reason 4.0.1, Vista SP1 Brendan
    • Jan 01 2011 | 5:15 pm
      First.. What errors did you get? 'tis a bit hard to debug problems if all you say is that you got errors without mentioning them.
      Second; you say that you're trying to use ad_rewire. But that does not fit what you're trying to do; that driver is used whenever you use Max as a rewire slave, not as a master. And in a combo Max Reason there is no other option than that Max becomes the master.
      Anyway, its a bit hard to determine what might have gone wrong, so maybe this patch ('ReWire Controller') can help. Load the patch, then load Reason. If all goes well then Reason starts as a rewire slave.
      Now find Reason amongst the 'Rewire devices' and set the inputs accordingly (usually 'Mix L' and 'Mix R'). Turn up the volume (use the slider at the bottom, that controls both channels) and make Reason play something (you'll probably need to use the sequencer and the mouse, my patch does not control midi).
      And that should be enough to make this work.
      As soon as you selected Reason as a rewire device (see above) you should get this message in your Max window:
      rewire~: opened device Reason
      Hope this helps!
      Hmm, I'll attach my patch instead of copy/paste, it seems to get a bit long otherwise...
    • Jan 01 2011 | 8:24 pm
      ShellUser, it worked to the beat, thanks a lot for the help!!! now in theory I can map 64 channels to different knobs ?.. its cool too get things working smoothly in the new year!
    • Jun 14 2013 | 7:18 am
      i have a problem within reason 5. it seems my rewire folder has disappeared and I cant use pro tools and reason together.