recording problems with pfft~.

    Feb 19 2006 | 6:03 pm
    when i use pfft~ objects, i am not able to record sound from within max/msp. the files end up being 54b when trying to record in 16 bit and 72b when in 32 bit.
    I'm thinking that it might have something to do with the i/o vector size seems unchangeable at 440, and that the signal vector size can only be varied from 1 to 32.
    I have tested this with a different soundcard with i/o vector size 512 and signal vector size 64 which works fine, and it was that which made me think that the problem lies with the emu 1616 cardbus soundcard that i'm using.
    I have tried fft sizes (frame sizes) 1024, 512, 2048, which also does not make any difference.
    So, can the i/o or signal vector size interfere with fft processing (maybe because the vector size 440 is not a power of two?), and if so does anyone know if there's there anything I can do about this?
    Kind regards Martin Aa

    • Feb 19 2006 | 8:08 pm
    • Feb 21 2006 | 4:15 pm
      yes, this problem occurs whenever pfft~ is involved, also with the turorial patches.
      The i/o vector size of 440 is displayed in the dsp status menu.
      I have tried to connect a record~ object to it, but when I turn on the dsp max crashes...!
      All else than recording works just fine.
      I would really appreaciate help on this, so thank you for involving!
      Martin Aa