Resolution of Jit.GL.Render


    Dec 29 2012 | 5:55 pm
    Hi, I'm trying to get OpenGL in to a matrix, and I want to be able to readily set the resolution. However, it's not working how I expect, and when I try to set the dimensions it does not seem responsive. Can anyone help me to understand the object better?
    My patch is rigged up to give some simple OpenGL graphics, and to render to a matrix. However, the resolution doesn't seem to be being set.

    • Dec 29 2012 | 6:58 pm
      Try this. Jit.gl.render gets its resolution from its render destination. In this case the matrix so it should be set explicitly there.
    • Dec 29 2012 | 7:02 pm
      Here's the same but stripped of the confusing @drawto's.
    • Dec 29 2012 | 9:31 pm
      Hey dtr, thanks for the response.
      When I try sending the matrix dimensions settings to go from 1080 to 720, the image then appears cropped. Do you get this too? I wonder how to stop this cropping and preserve the full frame?
    • Dec 29 2012 | 10:00 pm
      Not entirely sure why that's happening but here's an alternative. The matrix will have the same size as the render destination window.
    • Dec 30 2012 | 5:59 am
      Interesting. Your patch seems to work as expected. I tried recreating my problem after looking through Tutorial 31, and am still having the same issue - it seems to be that new matrix dimensions are relative to the initial dimensions, as illustrated in the patch below.
      It still seems strange that I can't change the dimensions in the way expected :-?
      I wonder what I am overlooking??
    • Dec 30 2012 | 9:35 pm
      you can fix this problem by re-sending the drawto attribute to jit.gl.render after changing the matrix dimensions.
      eg, send dim 160 120 to the matrix, then send drawto clyde to the gl.render.
    • Dec 31 2012 | 3:32 am
      That has sorted me out! Much appreciated
      Is this a bug, or just the way it's supposed to work?
    • Jun 27 2014 | 3:41 pm
      How can I manually control resolution of gl.render output texture regardless of jit.window size ? ("drawto matrix" do not count).
    • Jun 27 2014 | 5:31 pm
      jit.gl.node @capture 1 @adap 0 @dim width height
    • Jun 27 2014 | 6:44 pm
      output texture of jit.gl.node will desired resolution, but then we send it to the jit.gl.videoplane "master" render still has resolution of jit.window. right?
    • Jun 27 2014 | 9:18 pm
      No, jit.gl.videoplane just accepts the resolution of whats coming in. If your videoplane has a lower resolution coming than the master setting (jit.window) and you make it full screen then it will be pixelated, which makes perfect sense.
    • Jun 28 2014 | 2:02 pm
      ok!)
    • May 18 2017 | 9:09 am
      im having a problem with the resolution of the wave-forms in my patch, it seems that having added some elements in the patch has lowered the resolution in some way, especially after adding syphon (not integrated in this patch here). maybe someone has an idea about what what im doing wrong - i tried it with equalling all dimensions and sizes, but there seems to be something that i am not aware of...
    • May 18 2017 | 5:59 pm
      hi lyve forms.
      if you want some help tracking down your issues, i'd recommend you clean up your patch. at the very least fix the errors that are generated in the max console.
      if you can strip your patch down to only the elements that are drawing incorrectly, people will be more likely to offer help
    • May 19 2017 | 6:47 am
      hi rob
      thanks for your response. i left the other elements in & already took some other stuff out, because i had the feeling that whenever i add something new, the resolution goes down. but i took the other stuff out now, as well. resolution stays very low, it seems.
      the error in the console "jit.gl.render: liss1 is not a valid context, it is a jit_gl_node" is a bit cryptic to me too, since no node is named that way. i get it with "liss2", as well, in the other patch/es for this. thank you for taking a look already, i really feel a bit stuck & don't really know what the missing link is.
      many thanks for your help
    • May 19 2017 | 4:53 pm
      your patch is completely broken, and you have a ton of errors in the max window on startup. disable rendering on patch open so you can start isolating and solving those errros.
      for starters, you have jit.world and jit.gl.renders with the same context name. jit.world is a replacement for jit.gl.render and jit.window, so you need to either get rid of those gl.render objects and study how jit.world works, or change the jit.world to a jit.window.
    • May 21 2017 | 11:13 am
      ive cleaned up as far as i can see, is there anything someone can tell why jit.window doesnt work and syphon makes the resol go down ? meanwhile, the (still lo_res) shapes disappeared completely, and cant tell from the jit.window help & reference files, plus forum search what ive implemented wrong... would someone mind taking a look? the patch is pretty simple. thank you so much!!!
    • May 22 2017 | 3:31 pm
      my best guess as to what you're trying to achieve, is to render a jit.gl.mesh from two jit.gl.camera viewports to two jit.world contexts, and then combine those two view captures with a jit.gl.pix and send them to jit.gl.syphon.
    • May 23 2017 | 2:37 pm
      hi rob, yes, this is very helpful. syphon records it now & resolution is much better, too - though the lines are still not clear, but idk if thats a general issue or due to my primordial skills... thanks a lot :)
      (the two jit.world are used for projection & one syphon for on-screen recording, to work on the av only, without projections & record little snippets from that)